'명령어실행'에 해당되는 글 1건

  1. 2015.11.12 Apache commons-collection 라이브러리 원격코드실행 취약점
2015.11.12 18:45

Apache commons-collection 라이브러리 원격코드실행 취약점

□ 개요

자바 관련 공통 컴포넌트 개발을 위한 Apache commons-collection 라이브러리[1]에서원격코드실행 취약점이 발견

공격자가 취약한 대상 서비스에 악의적인 데이터를 삽입하여 전송할 경우 시스템 명령어 실행악성코드 다운로드 및 실행 등이 가능

 

□ 취약점 내용

Apache commons-collection 라이브러리의 InvokerTransformer함수에서 신뢰되지 않은 데이터(명령어 등)를 검증 하지 않아 공격자가 원격에서 명령 실행이 가능

 

□ 영향 받는 소프트웨어

o Apache commons-collection 라이브러리 Version 3.0 ~ 4.0

o Apache commons-collection 라이브러리를 사용하는 자바 기반 애플리케이션

   - Oracle WebLogic, IBM WebSphere, RedHat JBoss, Jenkins, OpenNMS 

 

□ 권고 사항 

취약점에 대한 보안 업데이트가 발표될 때 까지 네트워크 보안 시스템 등을 통해 대응 권고 

   - 네트워크 방화벽 룰 설정을 통해 신뢰된 원격지에서만 서비스에 접근 가능하도록 설정

    ※ 비인가 원격지에서 영향받는 서비스 포트  접근을 [디폴트 포트 예WebLogic(7001), WebShpere(8880), JBoss(8080), OpenNMS(1099) 등] 검토하여 탐지 또는 차단

   - 네트워크 패킷에 취약점과 관련된 문자열인 InvocationHandler, AnnotationInvocationHandler 등

     공격과 관련된 내용이 포함되어 있을 경우 탐지 또는 필터링

 

□ 기타 문의사항 

한국인터넷진흥원 인터넷침해대응센터국번없이 118

 

[참고사이트]

[1] https://commons.apache.org/proper/commons-collections/

[2] https://issues.apache.org/jira/browse/COLLECTIONS-580

[3] http://svn.apache.org/viewvc?view=revision&revision=1713307


Trackback 0 Comment 0