2009. 9. 4. 19:08

이더채널(Ether Channel)의 PAgP와 LACP 설정

이더채널은 개개의 Fast Ethernet과 Gigabit Ethernet으로 아래 그림과 같이 논리적으로 묶을 수 있다. 이더채널은 스위치와 스위치 혹은 호스트 사이에서 Full-Duplex 대역을 800Mbps(Fast) 혹은 8Gbps(Gigabit)를 제공한다.

- 기본 구성 라인

1. 이더채널내의 모든 포트는 같은 vlan에 소속.
2. 이더채널내의 모든 포트는 같은 speed와 duplex
3. 이더채널내의 모든 포트는 SPAN(Switched port analyzer)이면 안됨.
4. 이더채널을 트렁크로 설정했다면 모든 포트는 같은 트렁크모드로 구성
5. 이더채널은 보안 설정이 되어 있는 포트들은 구성 안 함.
 
물리적 포트와 논리적 포트 채널들과 채널 그룹들과의 관계
 
- 각각의 이더채널은 논리적인 1~64의 포트채널 번호를 가질 수 있다.
ex) L2설정: channel-group [1~64] ... (인터페이스모드)
     L3설정: interface port-chnnel [1~64] ... (글로벌 모드)
 
 
한 포트가 이더채널에 들어갈 때, 저 포트를 위해 물리적인 인터페이스는 셧 다운 상태가 된다. 그 포트가 포트채널에서 나갈 때는 그 물리적인 인터페이스는 멈추져 버리고 이더채널 가입하기 전에 가졌던 똑같은 설정을 가진다.
 
[ PAgP패킷과 LACP패킷 교환 방법 ] 필요하신 분은 영문으로 보세요~
 
Exchanging PAgP Packets
Both the auto and desirable PAgP modes allow interfaces to negotiate with partner interfaces to determine if they can form an EtherChannel based on criteria such as interface speed and, for Layer 2 EtherChannels, trunking state and VLAN numbers.
 
Interfaces can form an EtherChannel when they are in different PAgP modes as long as the modes are compatible. For example:
 
An interface in the desirable mode can form an EtherChannel with another interface that is in the desirable or auto mode.
An interface in the auto mode can form an EtherChannel with another interface in the desirable mode.
 
An interface in the auto mode cannot form an EtherChannel with another interface that is also in the auto mode because neither interface starts PAgP negotiation.
An interface in the on mode that is added to a port channel is forced to have the same characteristics as the already existing on mode interfaces in the channel.
 
If your switch is connected to a partner that is PAgP-capable, you can configure the switch interface for nonsilent operation by using the non-silent keyword. If you do not specify non-silent with the auto or desirable mode, silent mode is assumed.
 
The silent mode is used when the switch is connected to a device that is not PAgP-capable and seldom, if ever, sends packets. An example of a silent partner is a file server or a packet analyzer that is not generating traffic.
 
In this case, running PAgP on a physical port connected to a silent partner prevents that switch port from ever becoming operational; however, the silent setting allows PAgP to operate, to attach the interface to a channel group, and to use the interface for transmission.

An Etherchannel cannot be configured in both the PAgP and LACP modes.
 
Exchanging LACP Packets
Both the active and passive LACP modes allow interfaces to negotiate with partner interfaces to determine if they can form an EtherChannel based on criteria such as interface speed and, for Layer 2 EtherChannels, trunking state and VLAN numbers.
 
Interfaces can form an EtherChannel when they are in different LACP modes as long as the modes are compatible. For example:
 
An interface in the active mode can form an EtherChannel with another interface that is in the active or passive mode.
An interface in the active mode can form an EtherChannel with another interface in the passive mode.
 
An interface in the passive mode cannot form an EtherChannel with another interface that is also in the passive mode because neither interface starts LACP negotiation.
 
An interface in the on mode that is added to a port channel is forced to have the same characteristics as the already existing on mode interfaces in the channel.
 
An Etherchannel cannot be configured in both the PAgP and LACP modes.
 
이더채널의 프로토콜 종류
 
- Cisco PAgP(Port Aggregation Protocol)
- IEEE 802.3AD LACP(Link Aggregation Control Protocol)
 
기본 이더채널 설정
 
Feature
Default Setting

Channel

groups

None assigned.

Layer 3 port-channel logical interface

None defined.

PAgP mode

No default.

PAgP learn method

Aggregate-port learning on all interfaces.

PAgP

priority

128 on all interfaces.

LACP learn method

Aggregate-port learning on all interfaces.

LACP

priority

32768 on all interfaces.

Load

balancing

Load distribution on the switch is based on the source-MAC address of the incoming packet. Load distribution based on the source and destination IP address is also enabled for routed IP traffic.

 
 
L2 이더채널의 설정

Switch# configure terminal
Switch(config)# interface range gigabitethernet0/4 -5
Switch(config-if-range)# switchport mode access
Switch(config-if-range)# switchport access vlan 10
Switch(config-if-range)# channel-group 5 mode desirable
Switch(config-if-range)# end 

 
L3 이더채널의 설정
 
Switch# configure terminal
Switch(config)# interface port-channel 5
Switch(config-if)# no switchport
Switch(config-if)# ip address 172.10.20.10 255.255.255.0
Switch(config-if)# end
 
 
물리적인 인터페이스 설정
 
Switch# configure terminal
Switch(config)# interface range gigabitethernet0/4 -5
Switch(config-if-range)# no ip address
Switch(config-if-range)# channel-group 5 mode desirable
Switch(config-if-range)# end
 
Portchannel Protocol의 Mode 종류:
 
- auto: 단지 PAgP 장비가 감지되어졌다면 PAgP로 활성화된다. 상대편 장비로 PAgP 패킷을 받았을때 그 포트는 PAgP로 연결을 맺지만, 먼저 PAgP 패킷 Negotiation을 시작하지 않는 Passive negotiating 상태로 포트가 된다.
 
- desirable: 무조건적으로 PAgP를 활성화한다. 그 포트는 PAgP 패킷을 보내는것에 의해 다른 포트들과 Negotiation을 맺는 Active negotiating 상태로 포트가 된다.
 
- on: PAgP 혹은 LACP 없이 이더채널화 하기 위한 것이다. ON 모드를 이용한, ON 모드의 한 포트 그룹이 있을때 이용가능한 이더채널은 단지 ON 모드에서 또 다른 하나의 포트 그룹[이더채널]과 연결되어진다. 엔지니어는 이더채널 맴버들이 다른 스위치들로부터 있을때 스위치 스택(Cross-stack EtherChannel)설정에서 ON 키워드를 사용해야 한다.
 
- non-Silent: (Optional) 당신의 스위치가 PAgP를 수용할 수 있는 파트너와 연결되어져 있다면, 그 포트가 auto나 desirable일때 nonsilent 동작을 위하여 스위치 포트를 설정한다.
만약 당신이 non-silent를 명시하지 않는다면, Silent를 할당받게 된다. silent 설정은 파일 서버 혹은 패킷 분석기로의 연결을 위해서 있다. 이 설정은 동작하기 위해, 채널 그룹으로 포트를 붙이기 위해, 전송을 위한 그 포트를 사용하기 위해 PAgP를 허락한다.
 
- active: 단지 LACP장비가 감지되어진다면 LACP를 활성화시킨다. Active는 LACP 패킷을 보내기지는것에 의해 다른 포트와 함께 그 포트를 Negotiation을 하는 active negotiating 상태로 포트를 둔다.
 
- passive: 그 포트를 LACP를 활성화시키고 PAgP 패킷을 받았을때 그 포트는 연결을 맺지만, 먼저 PAgP 패킷 Negotiation을 시작하지 않는 Passive negotiating 상태로 포트를 둔다.


Port channel , 로드벨런싱 설정하기


Cisco
에지 장비와  Port channel 설정하기

interface Port-channel11

  description S

  switchport access vlan 280

  switchport mode access

 no ip address

interface Vlan280

  description S

  ip address 60.1.1.217 255.255.255.252

Ip route 200.1.0.0 255.255.255.0 60.1.1.218
interface FastEthernet0/4

 description S+MAN+KTL_2003002195+100M

 switchport access vlan 280

 switchport mode access

 no ip address

 duplex full

 speed 100

 channel-group 11 mode on

interface FastEthernet0/5

 description S+MAN+KTL_2003002195+100M

 switchport access vlan 280

 switchport mode access

 no ip address

 duplex full

 speed 100

channel-group 11 mode on

로커스 406F에서 Port channel 설정하기

vlan database

 vlan 100

 vlan 200

!

interface fa0/1

 description +++ KTL +++

 speed 100 full-duplex

 switchport access vlan 200

!

interface fa0/7

 description +++ uplink +++

 no switchport

 port-group

interface fa0/8

 description +++ uplink +++

 no switchport

 port-group

!

interface po0

 switchport access vlan 100    

!

interface vlan100

 ip address 60.1.1.218 255.255.255.252  // WAN구간 IP

또는

(interface po0

 no switchport

 ip address 61.1.1.114 255.255.255.252 )

!

interface vlan200

 ip address 60.1.2255.255.255.248

 

ip route 0.0.0.0/0 60.1.1.217

확인

Switch#  show  port-group

ID status load-balance   Member-Port-List

-----------------------------------------------------------------

3  down   Round-Robin   fa9/1 fa9/2

Port 그룹을 로드벨런싱으로

Switch(config)# interface po3

Switch(config-if-po3)# load-balancing  dst-mac

Switch(config-if-po3)# end

 

Switch# show port-group

ID status load-balance   Member-Port-List

-----------------------------------------------------------------

3  down   Dest MAC   fa9/1 fa9/2


출처 : http://blog.naver.com/heavenksm

Trackback 1 Comment 1
  1. catalyst3550 2009.09.04 19:18 address edit & del reply

    3550 스위치 설정 가이드
    http://www.cisco.com/en/US/docs/switches/lan/catalyst3550/software/release/12.1_8_ea1/configuration/guide/swethchl.html