'그누보드'에 해당되는 글 8건

  1. 2012.11.01 국내 공개 웹 게시판(그누보드) 보안 업데이트
  2. 2012.10.12 국내 공개 웹 게시판(그누보드) 보안 업데이트 (1)
  3. 2012.07.02 국내 공개 웹게시판(그누보드) XSS 보안 업데이트
2012. 11. 1. 18:53

국내 공개 웹 게시판(그누보드) 보안 업데이트

개요

  • 국내 PHP기반의 공개 웹 게시판인 그누보드에서 SQL Injection 보안취약점이 발견됨
  • 취약한 버전을 사용하고 있을 경우, 홈페이지 데이터베이스 계정 정보가 유출되는 등의 피해를 입을 수 있으므로 웹 관리자의 적극적인 조치 필요

해당시스템

  • 영향받는 소프트웨어
    - 그누보드 4.36.07 및 이전 버전

해결방안

  • 기존 그누보드 사용자는 업데이트가 적용된 상위 버전(4.36.08 이상)으로 업그레이드 [1]
    ※ 패치 작업 이전에 원본 파일은 백업 필요
  • 그누보드를 새로 설치하는 이용자
    - 반드시 보안패치가 적용된 최신버전을 설치

용어정리

  • PHP : 동적인 웹사이트를 위한 서버 측 스크립트 언어
  • SQL Injection : 웹 응용 프로그램에 강제로 SQL구문을 삽입하여 내부 데이터베이스 서버의 데이터를 유출 및 변조하고 관리자 인증을 우회할 수 있는 공격
  • 그누보드 : PHP언어로 작성된 홈페이지용 게시판 소프트웨어 또는 프레임 워크

문의사항

  • 한국인터넷진흥원 인터넷침해대응센터: 국번없이 118

기타

  • 본 보안취약점은 Krcert 홈페이지를 통해 김동현(Stealth in BlackFalcon)님께서 제공해주셨습니다.

[참고사이트]
[1] http://sir.co.kr/bbs/board.php?bo_table=g4_pds&wr_id=8052&page=1


Trackback 0 Comment 0
2012. 10. 12. 18:11

국내 공개 웹 게시판(그누보드) 보안 업데이트

개요

  • 국내 PHP기반의 공개 웹 게시판인 그누보드에서 XSS 취약점이 발견됨
  • 취약한 버전을 사용하고 있을 경우, 홈페이지 해킹에 의한 계정 탈취 등의 피해를 입을 수 있으므로 웹 관리자의 적극적인 조치 필요

해당시스템

  • 영향받는 소프트웨어
    - 그누보드 4.36.05 및 이전 버전

해결방안

  • 기존 그누보드 사용자는 업데이트가 적용된 상위 버전으로 업그레이드 [1]
    ※ 패치 작업 이전에 원본 파일은 백업 필요
  • 그누보드를 새로 설치하는 이용자
    - 반드시 보안패치가 적용된 최신버전(4.36.06 이상)을 설치

용어 정리

  • PHP : 동적인 웹사이트를 위한 서버 측 스크립트 언어
  • XSS (Cross Site Scripting) : 웹사이트 관리자가 아닌 이가 웹페이지에 클라이언트 사이드 스크립트를 삽입하여 다른 사용자가 이를 실행하게끔 허용하는 취약점
    그누보드 : PHP언어로 작성된 홈페이지용 게시판 소프트웨어 또는 프레임 워크

문의사항

  • 한국인터넷진흥원 인터넷침해대응센터: 국번없이 118

 

기타

  • 본 취약점은 Krcert 홈페이지를 통해 김강섭(unsecurity)님께서 제공해주셨습니다.

[참고사이트]
[1] http://sir.co.kr/bbs/board.php?bo_table=g4_pds&wr_id=7969&page=1


Trackback 0 Comment 1
  1. 2012.10.13 21:51 address edit & del reply

    비밀댓글입니다

2012. 7. 2. 18:51

국내 공개 웹게시판(그누보드) XSS 보안 업데이트

□ 개요

  o 국내 PHP기반의 공개 웹 게시판인 그누보드에서 XSS 취약점이 발견됨[1]

  o 취약한 버전을 사용하고 있을 경우, 홈페이지 해킹에 의한 관리자 계정 탈취 및 악성코드 유포지로 악용되는 등의 피해를 입을 수 있으므로 웹 관리자의 적극적인 조치 필요

 

□ 해당시스템

  o 영향받는 소프트웨어[1]

     - 그누보드 4.36.00 및 이전 버전

 

□ 해결방안

  o 그누보드 4.36.00 및 이전버전 사용자는 4.36.02버전으로 업데이트[1]

    ※ 패치 작업 이전에 원본 파일은 백업 필요

  o 그누보드를 새로 설치하는 이용자

     - 반드시 보안패치가 적용된 최신버전(4.36.02)을 설치

 

□ 용어 정리

  o PHP : 동적인 웹사이트를 위한 서버 측 스크립트 언어

  o XSS (Cross Site Scripting) : 웹사이트 관리자가 아닌 이가 웹페이지에 클라이언트 사이드 스크립트를 삽입하여 다른 사용자가 이를 실행하게끔 허용하는 취약점

  o 그누보드 : PHP언어로 작성된 홈페이지용 게시판 소프트웨어 또는 프레임 워크

 

□ 기타 문의사항

  o 한국인터넷진흥원 인터넷침해대응센터: 국번없이 118

 

[참고사이트]

[1] http://sir.co.kr/bbs/board.php?bo_table=g4_pds&wr_id=7707


Trackback 0 Comment 0