본문 바로가기

보안서버9

728x90
OpenSSL 다중 취약점 보안업데이트 □ 개요 o OpenSSL에서 발생한 서비스 거부 공격 취약점, Out-of-bounds 읽기/쓰기 취약점 등 총 14개의 취약점을 보완한 보안 업데이트를 발표함[1] □ 설명 o 클라이언트에서 많은 양의 OCSP 요청을 보낼 경우 서비스 거부가 발생할 수 있는 취약점(CVE-2016-6304) o 특수하게 조작 된 레코드를 보낼 경우 SSL_peek의 결함으로 인해 서비스 거부가 발생할 수 있는 취약점(CVE-2016-6305) o 3DES 대칭암호의 암호스위트를 지원하는 SSL/TLS 프로토콜에서 SWEET32 공격이 가능한 취약점(CVE-2016-2183) o MDC2_Update() 함수에서 오버플로우가 발생 해 Out-of-bounds 쓰기가 가능한 취약점(CVE-2016-6303) o tls_.. 2016. 9. 26.
OpenSSL 긴급 보안 업데이트 □ 개요 o 3월 1일(현지시간) 오픈SSL은 SSLv2 규격(Protocol)에 대한 긴급 업데이트 발표[1] o SSL 취약점을 이용한 신종 공격 방식인 DROWN, CacheBleed에 대한 보안 업데이트 등 - DROWN(Decrypting RSA with Obsolete and Weakened eNcryption) - CacheBleed: 인텔 프로세서의 Cache-bank 충돌로 인한 정보 노출을 이용한 부채널 공격 □ 영향 받는 사용자 - OpenSSL 1.0.2 사용자: 1.0.2g로 업데이트 - OpenSSL 1.0.1 사용자: 1.0.1s로 업데이트 □ 업데이트 내용 o SSLv2 프로토콜 비활성화 기본 설정 및 SSLv2 EXPORT 암호화 제거 등 □ 취약점 내용 및 권고 사항 o .. 2016. 3. 2.
OpenSSL 취약점 보안업데이트 □ 개요 o OpenSSL에서는 키 교환에서 중간자 공격이 가능한 취약점, SSLv2의 핸드셰이크 전송에서 중간자 공격이 가능한 취약점 등 2개의 취약점을 보완한 보안업데이트를 발표[1] □ 설명 o TLS 프로토콜의 Diffie-Hellman 키 교환에서 소수 값 처리 중 MITM(man-in-the-middle)공격이 가능한 취약점(CVE-2016-0701) o SSLv2을 사용할 경우 조작된 핸드셰이크 전송을 통한 MITM(man-in-the-middle)공격이 가능한 취약점(CVE-2015-3197) □ 해당 시스템 o 영향 받는 제품 및 버전 - OpenSSL 1.0.2 대 버전 - OpenSSL 1.0.1 대 버전 □ 해결 방안 o 해당 취약점에 영향 받는 버전의 사용자는 아래 버전으로 업데이.. 2016. 2. 1.
웹 브라우저 암호 고도화 정책에 따른 주의 개요MS와 Google 등 美 NIST의 권고에 따라 ‘16년 6월부터 SSL 인증서 및 코드서명 인증서 등 암호를 SHA-1에서 SHA-2로 상향예정(’16년 6월) 설명현행 SHA-1(160비트) 기반 웹서비스 인증서 암호 체계를 ‘16년 6월부터 SHA-2(224~512비트) 기반 인증서 체계로 고도화(’16년 5월까지 SHA-1 체계 병행 허용)‘16년 6월부터 기존 SHA-1 기반 인증서를 사용할 수 없기 때문에, 웹사이트(포털, 게임, 상거래 등) 운영자가 해당 웹서비스 인증서(SSL, 코드서명)를 신규 및 재발급, 갱신하지 않을 경우 웹사이트 접속 오류 및 실행파일 설치 오류(액티브X 등) 발생 영향받는 플랫폼 및 브라우저플랫폼브라우저명SHA-2 알고리즘 미지원플랫폼브라우저PCInternet.. 2016. 1. 5.
OpenSSL 취약점 보안업데이트 □ 개요 o OpenSSL에서는 서비스 거부 공격 취약점, Race condition 취약점 등 5개의 취약점을 보완한 보안업데이트를 발표[1] □ 설명 o NB_mod_exp 함수에서 값을 제곱 처리 할 때 발생하는 취약점 (CVE-2015-3193) o 인증서 검증시 PSS 파라미터 부재로 인한 서비스 거부 취약점 (CVE-2015-3194) o X509_ATTRIBUTE 구조체에서 발생하는 OpenSSL 메모리 누수 취약점 (CVE-2015-3195) o PSK Identify hint 처리 중 발생하는 Race condition 취약점 (CVE-2015-3196) o ServerKyExchange의 값을 처리 중에 발생하는 서비스 거부 공격 취약점 (CVE-2015-1794) □ 해당 시스템 o .. 2015. 12. 8.
728x90