'EIGRP'에 해당되는 글 3건

  1. 2014.04.07 Assigned Internet Protocol Numbers (1)
  2. 2010.07.02 EIGRP equal/unequal [metric/cost] paths load balancing
  3. 2009.12.01 PBR - 정책기반 라우팅 설정
2014.04.07 18:20

Assigned Internet Protocol Numbers

Assigned Internet Protocol Numbers

DecimalKeyword Protocol IPv6 Extension Header Reference 
0HOPOPTIPv6 Hop-by-Hop OptionY[RFC2460]
1ICMPInternet Control Message[RFC792]
2IGMPInternet Group Management[RFC1112]
3GGPGateway-to-Gateway[RFC823]
4IPv4IPv4 encapsulation[RFC2003]
5STStream[RFC1190][RFC1819]
6TCPTransmission Control[RFC793]
7CBTCBT[Tony_Ballardie]
8EGPExterior Gateway Protocol[RFC888][David_Mills]
9IGPany private interior gateway (used by Cisco for their IGRP)[Internet_Assigned_Numbers_Authority]
10BBN-RCC-MONBBN RCC Monitoring[Steve_Chipman]
11NVP-IINetwork Voice Protocol[RFC741][Steve_Casner]
12PUPPUP[Boggs, D., J. Shoch, E. Taft, and R. Metcalfe, "PUP: An Internetwork Architecture", XEROX Palo Alto Research Center, CSL-79-10, July 1979; also in IEEE Transactions on Communication, Volume COM-28, Number 4, April 1980.][[XEROX]]
13ARGUSARGUS[Robert_W_Scheifler]
14EMCONEMCON[<mystery contact>]
15XNETCross Net Debugger[Haverty, J., "XNET Formats for Internet Protocol Version 4", IEN 158, October 1980.][Jack_Haverty]
16CHAOSChaos[J_Noel_Chiappa]
17UDPUser Datagram[RFC768][Jon_Postel]
18MUXMultiplexing[Cohen, D. and J. Postel, "Multiplexing Protocol", IEN 90, USC/Information Sciences Institute, May 1979.][Jon_Postel]
19DCN-MEASDCN Measurement Subsystems[David_Mills]
20HMPHost Monitoring[RFC869][Bob_Hinden]
21PRMPacket Radio Measurement[Zaw_Sing_Su]
22XNS-IDPXEROX NS IDP["The Ethernet, A Local Area Network: Data Link Layer and Physical Layer Specification", AA-K759B-TK, Digital Equipment Corporation, Maynard, MA. Also as: "The Ethernet - A Local Area Network", Version 1.0, Digital Equipment Corporation, Intel Corporation, Xerox Corporation, September 1980. And: "The Ethernet, A Local Area Network: Data Link Layer and Physical Layer Specifications", Digital, Intel and Xerox, November 1982. And: XEROX, "The Ethernet, A Local Area Network: Data Link Layer and Physical Layer Specification", X3T51/80-50, Xerox Corporation, Stamford, CT., October 1980.][[XEROX]]
23TRUNK-1Trunk-1[Barry_Boehm]
24TRUNK-2Trunk-2[Barry_Boehm]
25LEAF-1Leaf-1[Barry_Boehm]
26LEAF-2Leaf-2[Barry_Boehm]
27RDPReliable Data Protocol[RFC908][Bob_Hinden]
28IRTPInternet Reliable Transaction[RFC938][Trudy_Miller]
29ISO-TP4ISO Transport Protocol Class 4[RFC905][<mystery contact>]
30NETBLTBulk Data Transfer Protocol[RFC969][David_Clark]
31MFE-NSPMFE Network Services Protocol[Shuttleworth, B., "A Documentary of MFENet, a National Computer Network", UCRL-52317, Lawrence Livermore Labs, Livermore, California, June 1977.][Barry_Howard]
32MERIT-INPMERIT Internodal Protocol[Hans_Werner_Braun]
33DCCPDatagram Congestion Control Protocol[RFC4340]
343PCThird Party Connect Protocol[Stuart_A_Friedberg]
35IDPRInter-Domain Policy Routing Protocol[Martha_Steenstrup]
36XTPXTP[Greg_Chesson]
37DDPDatagram Delivery Protocol[Wesley_Craig]
38IDPR-CMTPIDPR Control Message Transport Proto[Martha_Steenstrup]
39TP++TP++ Transport Protocol[Dirk_Fromhein]
40ILIL Transport Protocol[Dave_Presotto]
41IPv6IPv6 encapsulation[RFC2473]
42SDRPSource Demand Routing Protocol[Deborah_Estrin]
43IPv6-RouteRouting Header for IPv6Y[Steve_Deering]
44IPv6-FragFragment Header for IPv6Y[Steve_Deering]
45IDRPInter-Domain Routing Protocol[Sue_Hares]
46RSVPReservation Protocol[RFC2205][RFC3209][Bob_Braden]
47GREGeneric Routing Encapsulation[RFC1701][Tony_Li]
48DSRDynamic Source Routing Protocol[RFC4728]
49BNABNA[Gary Salamon]
50ESPEncap Security PayloadY[RFC4303]
51AHAuthentication HeaderY[RFC4302]
52I-NLSPIntegrated Net Layer Security TUBA[K_Robert_Glenn]
53SWIPEIP with Encryption[John_Ioannidis]
54NARPNBMA Address Resolution Protocol[RFC1735]
55MOBILEIP Mobility[Charlie_Perkins]
56TLSPTransport Layer Security Protocol using Kryptonet key management[Christer_Oberg]
57SKIPSKIP[Tom_Markson]
58IPv6-ICMPICMP for IPv6[RFC2460]
59IPv6-NoNxtNo Next Header for IPv6[RFC2460]
60IPv6-OptsDestination Options for IPv6Y[RFC2460]
61any host internal protocol[Internet_Assigned_Numbers_Authority]
62CFTPCFTP[Forsdick, H., "CFTP", Network Message, Bolt Beranek and Newman, January 1982.][Harry_Forsdick]
63any local network[Internet_Assigned_Numbers_Authority]
64SAT-EXPAKSATNET and Backroom EXPAK[Steven_Blumenthal]
65KRYPTOLANKryptolan[Paul Liu]
66RVDMIT Remote Virtual Disk Protocol[Michael_Greenwald]
67IPPCInternet Pluribus Packet Core[Steven_Blumenthal]
68any distributed file system[Internet_Assigned_Numbers_Authority]
69SAT-MONSATNET Monitoring[Steven_Blumenthal]
70VISAVISA Protocol[Gene_Tsudik]
71IPCVInternet Packet Core Utility[Steven_Blumenthal]
72CPNXComputer Protocol Network Executive[David Mittnacht]
73CPHBComputer Protocol Heart Beat[David Mittnacht]
74WSNWang Span Network[Victor Dafoulas]
75PVPPacket Video Protocol[Steve_Casner]
76BR-SAT-MONBackroom SATNET Monitoring[Steven_Blumenthal]
77SUN-NDSUN ND PROTOCOL-Temporary[William_Melohn]
78WB-MONWIDEBAND Monitoring[Steven_Blumenthal]
79WB-EXPAKWIDEBAND EXPAK[Steven_Blumenthal]
80ISO-IPISO Internet Protocol[Marshall_T_Rose]
81VMTPVMTP[Dave_Cheriton]
82SECURE-VMTPSECURE-VMTP[Dave_Cheriton]
83VINESVINES[Brian Horn]
84TTPTransaction Transport Protocol[Jim_Stevens]
84IPTMInternet Protocol Traffic Manager[Jim_Stevens]
85NSFNET-IGPNSFNET-IGP[Hans_Werner_Braun]
86DGPDissimilar Gateway Protocol[M/A-COM Government Systems, "Dissimilar Gateway Protocol Specification, Draft Version", Contract no. CS901145, November 16, 1987.][Mike_Little]
87TCFTCF[Guillermo_A_Loyola]
88EIGRPEIGRP[Cisco Systems, "Gateway Server Reference Manual", Manual Revision B, January 10, 1988.][Guenther_Schreiner]
89OSPFIGPOSPFIGP[RFC1583][RFC2328][RFC5340][John_Moy]
90Sprite-RPCSprite RPC Protocol[Welch, B., "The Sprite Remote Procedure Call System", Technical Report, UCB/Computer Science Dept., 86/302, University of California at Berkeley, June 1986.][Bruce Willins]
91LARPLocus Address Resolution Protocol[Brian Horn]
92MTPMulticast Transport Protocol[Susie_Armstrong]
93AX.25AX.25 Frames[Brian_Kantor]
94IPIPIP-within-IP Encapsulation Protocol[John_Ioannidis]
95MICPMobile Internetworking Control Pro.[John_Ioannidis]
96SCC-SPSemaphore Communications Sec. Pro.[Howard_Hart]
97ETHERIPEthernet-within-IP Encapsulation[RFC3378]
98ENCAPEncapsulation Header[RFC1241][Robert_Woodburn]
99any private encryption scheme[Internet_Assigned_Numbers_Authority]
100GMTPGMTP[[RXB5]]
101IFMPIpsilon Flow Management Protocol[Bob_Hinden][November 1995, 1997.]
102PNNIPNNI over IP[Ross_Callon]
103PIMProtocol Independent Multicast[RFC4601][Dino_Farinacci]
104ARISARIS[Nancy_Feldman]
105SCPSSCPS[Robert_Durst]
106QNXQNX[Michael_Hunter]
107A/NActive Networks[Bob_Braden]
108IPCompIP Payload Compression Protocol[RFC2393]
109SNPSitara Networks Protocol[Manickam_R_Sridhar]
110Compaq-PeerCompaq Peer Protocol[Victor_Volpe]
111IPX-in-IPIPX in IP[CJ_Lee]
112VRRPVirtual Router Redundancy Protocol[RFC5798]
113PGMPGM Reliable Transport Protocol[Tony_Speakman]
114any 0-hop protocol[Internet_Assigned_Numbers_Authority]
115L2TPLayer Two Tunneling Protocol[RFC3931][Bernard_Aboba]
116DDXD-II Data Exchange (DDX)[John_Worley]
117IATPInteractive Agent Transfer Protocol[John_Murphy]
118STPSchedule Transfer Protocol[Jean_Michel_Pittet]
119SRPSpectraLink Radio Protocol[Mark_Hamilton]
120UTIUTI[Peter_Lothberg]
121SMPSimple Message Protocol[Leif_Ekblad]
122SMSimple Multicast Protocol[Jon_Crowcroft][draft-perlman-simple-multicast]
123PTPPerformance Transparency Protocol[Michael_Welzl]
124ISIS over IPv4[Tony_Przygienda]
125FIRE[Criag_Partridge]
126CRTPCombat Radio Transport Protocol[Robert_Sautter]
127CRUDPCombat Radio User Datagram[Robert_Sautter]
128SSCOPMCE[Kurt_Waber]
129IPLT[[Hollbach]]
130SPSSecure Packet Shield[Bill_McIntosh]
131PIPEPrivate IP Encapsulation within IP[Bernhard_Petri]
132SCTPStream Control Transmission Protocol[Randall_R_Stewart]
133FCFibre Channel[Murali_Rajagopal][RFC6172]
134RSVP-E2E-IGNORE[RFC3175]
135Mobility HeaderY[RFC6275]
136UDPLite[RFC3828]
137MPLS-in-IP[RFC4023]
138manetMANET Protocols[RFC5498]
139HIPHost Identity ProtocolY[RFC5201]
140Shim6Shim6 ProtocolY[RFC5533]
141WESPWrapped Encapsulating Security Payload[RFC5840]
142ROHCRobust Header Compression[RFC5858]
143-252Unassigned[Internet_Assigned_Numbers_Authority]
253Use for experimentation and testingY[RFC3692]
254Use for experimentation and testingY[RFC3692]
255Reserved[Internet_Assigned_Numbers_Authority]



출처 : iana.org


Trackback 1 Comment 1
  1. 2014.04.07 18:22 address edit & del reply

    비밀댓글입니다

2010.07.02 13:18

EIGRP equal/unequal [metric/cost] paths load balancing

default[k1=1, k2=0, k3=1, k4=0, k5=0]

from Source R0 to destination R4 loopback 0 100.100.100.100

All serial segments Bandwidth, Delay are the same.

Equal path load balancing.


hostname R0
interface Serial0/0
 ip address 10.0.1.1 255.255.255.252
interface Serial0/1
 ip address 10.0.2.1 255.255.255.252
interface Serial0/2
 ip address 10.0.3.1 255.255.255.252
router eigrp 1
 network 10.0.1.1 0.0.0.0
 network 10.0.2.1 0.0.0.0
 network 10.0.3.1 0.0.0.0

 

hostname R1
interface Serial0/0
 ip address 10.1.1.1 255.255.255.252
interface Serial0/1
 ip address 10.0.1.2 255.255.255.252
router eigrp 1
 network 10.0.1.2 0.0.0.0
 network 10.1.1.1 0.0.0.0

 

hostname R2
interface Serial0/0
 ip address 10.1.2.1 255.255.255.252
interface Serial0/1
 ip address 10.0.2.2 255.255.255.252
router eigrp 1
 network 10.0.2.2 0.0.0.0
 network 10.1.2.1 0.0.0.0

 

hostname R3
interface Serial0/0
 ip address 10.1.3.1 255.255.255.252
interface Serial0/1
 ip address 10.0.3.2 255.255.255.252
router eigrp 1
 network 10.0.3.2 0.0.0.0
 network 10.1.3.1 0.0.0.0

 

hostname R4
interface Loopback0
 ip address 100.100.100.100 255.255.255.255
interface Serial0/0
 ip address 10.1.1.2 255.255.255.252
interface Serial0/1
 ip address 10.1.2.2 255.255.255.252
interface Serial0/2
 ip address 10.1.3.2 255.255.255.252
router eigrp 1
 network 10.1.1.2 0.0.0.0
 network 10.1.2.2 0.0.0.0
 network 10.1.3.2 0.0.0.0
 network 100.100.100.100 0.0.0.0

 

R0#show ip route [FD=(rounddown(10^7/the lowest bandwidth)+sum_dalay/10)*256=2401792]
D    100.0.0.0/8 [90/2401792] via 10.0.2.2, 00:05:29, Serial0/1
                 [90/2401792] via 10.0.1.2, 00:05:29, Serial0/0
                 [90/2401792] via 10.0.3.2, 00:05:29, Serial0/2
     10.0.0.0/30 is subnetted, 6 subnets
D       10.1.3.0 [90/2273792] via 10.0.3.2, 00:05:29, Serial0/2
C       10.0.2.0 is directly connected, Serial0/1
D       10.1.2.0 [90/2273792] via 10.0.2.2, 00:05:29, Serial0/1
C       10.0.3.0 is directly connected, Serial0/2
D       10.1.1.0 [90/2273792] via 10.0.1.2, 00:05:29, Serial0/0
C       10.0.1.0 is directly connected, Serial0/0

 

from R0 to R1, R2, R3 successor same metric(cost) [FD,AD] -- > equal load balancing

 

R0#traceroute 100.100.100.100

Type escape sequence to abort.
Tracing the route to 100.100.100.100

  1 10.0.2.2 20 msec
    10.0.3.2 44 msec
    10.0.1.2 72 msec
  2 10.1.2.2 124 msec
    10.1.3.2 88 msec
    10.1.1.2 60 msec


R0#show ip eigrp topology all-links
IP-EIGRP Topology Table for AS(1)/ID(10.0.3.1)

P 10.1.3.0/30, 1 successors, FD is 2273792, serno 5
         via 10.0.3.2 (2273792/1761792), Serial0/2
         via 10.0.2.2 (2785792/2273792), Serial0/1
         via 10.0.1.2 (2785792/2273792), Serial0/0
P 10.0.2.0/30, 1 successors, FD is 1761792, serno 2
         via Connected, Serial0/1
P 10.1.2.0/30, 1 successors, FD is 2273792, serno 8
         via 10.0.2.2 (2273792/1761792), Serial0/1
         via 10.0.3.2 (2785792/2273792), Serial0/2
         via 10.0.1.2 (2785792/2273792), Serial0/0
P 10.0.3.0/30, 1 successors, FD is 1761792, serno 3
         via Connected, Serial0/2
P 10.1.1.0/30, 1 successors, FD is 2273792, serno 4
         via 10.0.1.2 (2273792/1761792), Serial0/0
         via 10.0.3.2 (2785792/2273792), Serial0/2
         via 10.0.2.2 (2785792/2273792), Serial0/1
P 10.0.1.0/30, 1 successors, FD is 1761792, serno 1
         via Connected, Serial0/0
P 100.0.0.0/8, 3 successors, FD is 2401792, serno 10
         via 10.0.3.2 (2401792/1889792), Serial0/2   <-- successor
         via 10.0.1.2 (2401792/1889792), Serial0/0   <-- successor
         via 10.0.2.2 (2401792/1889792), Serial0/1   <-- successor up to 4 successors by default

                                                                          up to 6 manually [maximum-paths]

R0#show ip protocols        
Routing Protocol is "eigrp 1"
  Outgoing update filter list for all interfaces is
  Incoming update filter list for all interfaces is
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 1
  Automatic network summarization is in effect
  Routing for Networks:
    10.0.1.1/32
    10.0.2.1/32
    10.0.3.1/32
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.0.1.2              90      00:00:47
    10.0.2.2              90      00:00:47
    10.0.3.2              90      00:00:47
  Distance: internal 90 external 170

 

All serial segments Bandwidth, Delay are not the same.

Unequal load balancing path

 

hostname R0
interface Serial0/0
 bandwidth 10000000
 ip address 10.0.1.1 255.255.255.252
 delay 10
interface Serial0/1
 bandwidth 10000000
 ip address 10.0.2.1 255.255.255.252
 delay 15
interface Serial0/2
 bandwidth 10000000
 ip address 10.0.3.1 255.255.255.252
 delay 30
router eigrp 1
 network 10.0.1.1 0.0.0.0
 network 10.0.2.1 0.0.0.0
 network 10.0.3.1 0.0.0.0

 

hostname R1
interface Serial0/0
 bandwidth 10000000
 ip address 10.1.1.1 255.255.255.252
 delay 10
interface Serial0/1
 bandwidth 10000000
 ip address 10.0.1.2 255.255.255.252
 delay 10
router eigrp 1
 network 10.0.1.2 0.0.0.0
 network 10.1.1.1 0.0.0.0

 

hostname R2
interface Serial0/0
 bandwidth 10000000
 ip address 10.1.2.1 255.255.255.252
 delay 15
interface Serial0/1
 bandwidth 10000000
 ip address 10.0.2.2 255.255.255.252
 delay 15
router eigrp 1
 network 10.0.2.2 0.0.0.0
 network 10.1.2.1 0.0.0.0

 

hostname R3
interface Serial0/0
 bandwidth 10000000
 ip address 10.1.3.1 255.255.255.252
 delay 30
interface Serial0/1
 bandwidth 10000000
 ip address 10.0.3.2 255.255.255.252
 delay 30
router eigrp 1
 network 10.0.3.2 0.0.0.0
 network 10.1.3.1 0.0.0.0

 

hostname R4
interface Loopback0
 bandwidth 10000000
 ip address 100.100.100.100 255.255.255.255
 delay 20
interface Serial0/0
 bandwidth 10000000
 ip address 10.1.1.2 255.255.255.252
 delay 10
interface Serial0/1
 bandwidth 10000000
 ip address 10.1.2.2 255.255.255.252
 delay 15
interface Serial0/2
 bandwidth 10000000
 ip address 10.1.3.2 255.255.255.252
 delay 30
router eigrp 1
 network 10.1.1.2 0.0.0.0
 network 10.1.2.2 0.0.0.0
 network 10.1.3.2 0.0.0.0
 network 100.100.100.100 0.0.0.0

 

R0#show ip route
D    100.0.0.0/8 [90/10496] via 10.0.1.2, 00:09:58, Serial0/0      <- only successor
      10.0.0.0/30 is subnetted, 6 subnets
D       10.1.3.0 [90/13056] via 10.0.1.2, 00:09:58, Serial0/0
C       10.0.2.0 is directly connected, Serial0/1
D       10.1.2.0 [90/7936] via 10.0.2.2, 00:09:58, Serial0/1
C       10.0.3.0 is directly connected, Serial0/2
D       10.1.1.0 [90/5376] via 10.0.1.2, 00:09:58, Serial0/0
C       10.0.1.0 is directly connected, Serial0/0

 

R0#traceroute 100.100.100.100

Type escape sequence to abort.
Tracing the route to 100.100.100.100

  1 10.0.1.2 68 msec 28 msec 28 msec    <--- only successor
  2 10.1.1.2 48 msec 60 msec *

 

R0#show ip eigrp topology all-links
IP-EIGRP Topology Table for AS(1)/ID(10.0.3.1)

P 10.1.3.0/30, 1 successors, FD is 13056, serno 6
         via 10.0.1.2 (13056/10496), Serial0/0
         via 10.0.2.2 (15616/11776), Serial0/1
         via 10.0.3.2 (15616/7936), Serial0/2
P 10.0.2.0/30, 1 successors, FD is 4096, serno 2
         via Connected, Serial0/1
P 10.1.2.0/30, 1 successors, FD is 7936, serno 4
         via 10.0.2.2 (7936/4096), Serial0/1
         via 10.0.3.2 (19456/11776), Serial0/2
         via 10.0.1.2 (9216/6656), Serial0/0
P 10.0.3.0/30, 1 successors, FD is 7936, serno 3
         via Connected, Serial0/2
P 10.1.1.0/30, 1 successors, FD is 5376, serno 5
         via 10.0.1.2 (5376/2816), Serial0/0
         via 10.0.3.2 (18176/10496), Serial0/2
         via 10.0.2.2 (10496/6656), Serial0/1
P 10.0.1.0/30, 1 successors, FD is 2816, serno 1
         via Connected, Serial0/0
P 100.0.0.0/8, 1 successors, FD is 10496, serno 7
         via 10.0.1.2 (10496/7936), Serial0/0    <-- Successor, the lowest FD
         via 10.0.3.2 (20736/13056), Serial0/2  <-- NON-feasible successor, successor FD < R3 AD
         via 10.0.2.2 (13056/9216), Serial0/1    <-- Feasible successor,successor FD > R2 AD

 

Unequal path load balanced

 

hostname R0

router eigrp 1
 variance 2                  <---10496 * 2(variance) > AD value load balancing
 network 10.0.1.1 0.0.0.0
 network 10.0.2.1 0.0.0.0
 network 10.0.3.1 0.0.0.0

 

R0#show ip route
D    100.0.0.0/8 [90/13056] via 10.0.2.2, 00:01:57, Serial0/1  <-- feasible successor
                 [90/10496] via 10.0.1.2, 00:01:57, Serial0/0       <-- successor
     10.0.0.0/30 is subnetted, 6 subnets
D       10.1.3.0 [90/15616] via 10.0.3.2, 00:01:57, Serial0/2
                 [90/15616] via 10.0.2.2, 00:01:57, Serial0/1
                 [90/13056] via 10.0.1.2, 00:01:57, Serial0/0
C       10.0.2.0 is directly connected, Serial0/1
D       10.1.2.0 [90/7936] via 10.0.2.2, 00:01:57, Serial0/1
                 [90/9216] via 10.0.1.2, 00:01:57, Serial0/0
C       10.0.3.0 is directly connected, Serial0/2
D       10.1.1.0 [90/5376] via 10.0.1.2, 00:01:57, Serial0/0
C       10.0.1.0 is directly connected, Serial0/0

 

R0#traceroute 100.100.100.100

[Unequal Load Balanced]
Tracing the route to 100.100.100.100

  1 10.0.1.2 36 msec
    10.0.2.2 44 msec
    10.0.1.2 12 msec
  2 10.1.2.2 72 msec
    10.1.1.2 72 msec
    10.1.2.2 88 msec

 

R0#show ip eigrp topology all-links
P 10.1.3.0/30, 1 successors, FD is 13056, serno 10
         via 10.0.1.2 (13056/10496), Serial0/0
         via 10.0.3.2 (15616/7936), Serial0/2
         via 10.0.2.2 (15616/11776), Serial0/1
P 10.0.2.0/30, 1 successors, FD is 4096, serno 2
         via Connected, Serial0/1
P 10.1.2.0/30, 1 successors, FD is 7936, serno 4
         via 10.0.2.2 (7936/4096), Serial0/1
         via 10.0.1.2 (9216/6656), Serial0/0
         via 10.0.3.2 (19456/11776), Serial0/2
P 10.0.3.0/30, 1 successors, FD is 7936, serno 3
         via Connected, Serial0/2
P 10.1.1.0/30, 1 successors, FD is 5376, serno 5
         via 10.0.1.2 (5376/2816), Serial0/0
         via 10.0.2.2 (10496/6656), Serial0/1
         via 10.0.3.2 (18176/10496), Serial0/2
P 10.0.1.0/30, 1 successors, FD is 2816, serno 1
         via Connected, Serial0/0
P 100.0.0.0/8, 1 successors, FD is 10496, serno 11
         via 10.0.1.2 (10496/7936), Serial0/0     <- Successor, the lowest FD
         via 10.0.2.2 (13056/9216), Serial0/1     <- Feasible successor,successor FD > R2 AD    

         via 10.0.3.2 (20736/13056), Serial0/2   <- NON-feasible successor, successor FD < R3 AD



출처 : http://blog.naver.com/bobos_neo


Trackback 0 Comment 0
2009.12.01 09:22

PBR - 정책기반 라우팅 설정

PBR이란? Policy Based Routing
route-map을 이용하여 특정 조건에 해당하는 패킷을 라우팅 테이블과 상관없이 관리자가 원하는 곳으로 전송시키는 기능을 말한다. 
route-map에 해당되지 않는 패킷은 라우팅테이블에 따라 전송된다. PBR을 사용하면 패킷의 출발지 또는 목적지 주소에 따라 원하는 경로를 선택할 수 있기 때문에 경우에 따라 유용하다. 예를 들면 2개의 ISP를 신청중이라면 PBR사용해서 IP에 따라 ISP를 선택 사용할 수 있다.

1. PBR 설정
router(config)# access-list [엑세스리스트넘버] [permit | deny] [네트워크아이디] [외일드마스크]
 (PBR을 적용시킬 패킷을 엑세스리스트를 이용하여 지정)
router(config)# route-map [route-map이름] [permit | deny] [route-map 순서]
 (PBR에서 사용할 루트맵 생성)
router(config-route-map)# match ip address [엑세스리스트 넘버]
 (match 명령어를 사용하여 앞서 만든 엑세스리스트를 지정)
router(config-router-map)# set ip net-hop [route-list 정책이 맞을 경우 패킷을 전송할 아이피]
 (match명령어에 의해 지정된 패킷을 전송할 ip지정, 해당되는 패킷을 전송할 수도 드랍할 수도 있도록 설정 가능)
router(config-router-map)# exit
router(config)# interface [정책을 적용할 패킷이 들어오는 인터페이스]
 (패킷이 유입되는 인터페이스지정)
router(config-if)# ip policy route-map [route-map이름]
 (해당 인터페이스에 루트맵 설치) 

2. PBR 설정 실습
위 토폴로지는 eigrp로 구성되어 있다. 만약 PBR 정책을 적용하지 않는다면 R0에서 172.16.1.0을 패킷이 이동할 때,  R1을 지나 R3로 이동 할 것이다.
왜냐하면 eigrp는 기본적으로 비균등로드를 하지 않기 때문에 가장 빠른 경로를 선택하여 패킷을 전송한다.
        
그러나, route-map을 사용하여 PBR정책을 적용할 경우 라우팅테이블에 올라온 경로를 무시하고 정책대로 패킷의 경로를 지정 할 수 있는데 위 토폴로지에서는 192.168.1.0 /24 네트워크에서 유입되는 패킷을 R2를 경유해서 목적지 172.16.1.0 /24로 도착하게 정책을 설정 하였다.

1) PBR 정책 설정
R1(config)# access-list 1 permit 192.168.1.0 0.0.0.255
 (엑세스리스트를 사용하여 PBR에 적용시킬 리스트 1번을 만든다)
R1(config)# route-map psk permit 1   (첫번째 라우트맵을 psk란 이름으로 만듬)
R1(config-route-map)# match ip address 1    (엑세스리스트 1번이 유입될 경우.....
R1(config-route-map)# set ip next-hop 192.168.2.2                                           192.168.2.2 홉으로 보냄) 
R1(config-route-map)# exit
R1(config)# interface s1/0
R1(config-if)# ip policy route-map psk   (라우트맵 psk를 패킷이 유입되는 s1/0에 설치)

2) R1의 라우팅 테이블 

3) 192.168.1.0 /24 에서 172.16.1.0 /24로 패킷이 이동하는 결과
 
4) R1에서 debug ip policy 결과

3. PBR을 이용한 선택적인 메트릭 재분배
보통 다른 프로토콜사이에서 재분배를 하다보면 관리자가 직접 재분배로 인하여 외부도메인을 통해서 들어오는 패킷의 메트릭을 지정해야 한다.
그러나 관리자가직접 지정하는 메트릭은 실제로 서브넷마다 메트릭이 달라도 외부도메인에서 볼때 동일하게 적용되는 문제점을 가지고 있다.
그래서 PBR을 이용하여 조건을 지정해 서브넷 별로 메트릭을 다르게 설정할 수 있는데 방법은 다음과 같다.

(2. 번의) 일반적인 PBR설정에서는 유입되는 패킷(인터페이스에 적용설정)에 라우트맵을 적용하는 반면, 재분배에 적용시에는 라우터 설정모드에서 재분배 명령에 첨부하여 적용설정 한다.

    1) 정책설정 (인터페이스 주소 설정 제외)
      R2(config)# access-list 10 permit 199.172.0.0 0.0.2.255
      R2(config)# route-map ripospf permit 1
      R2(config-route-map)# match ip add 10
      R2(config-route-map)# set metric 100
      R2(config-route-map)# set metric-type type-1
      R2(config-route-map)# exit
      R2(config)# route-map ripospf permit 2
      R2(config)# router rip
      R2(config-route)# net 199.172.2.2
      R2(config-route)# net 199.172.1.2
      R2(config-route)# exit
      R2(config)# router ospf 1
      R2(config-route)# net 192.168.1.0 0.0.0.255 area 0
      R2(config-route)# re rip subnets route-map ripospf
      R2(config-route)# exit

      2) R3 (ospf라우터) 라우팅테이블 확인
      
      - R2 (재분배 라우터의 route-map 설정 확인)


1. R2에서 출발지 주소가 1.1.1.1 이고 목적지 주소가 1.1.4.4 인 패킷은 R2에서 S1/0.23 으로 전송하게 하자.
   (원래는 S1/0.32 로만 가게 되어있다. why? S1/0.32 가 bandwidth = 2Mbps 로 더 좋은 회선이기 때문에)

R2#debug ip policy
R2#conf t
R2(config)#ip access-list extended R1=>R4
R2(config-ext-nacl)#permit ip host 1.1.1.1 host 1.1.4.4
R2(config-ext-nacl)#exit
R2(config)#route-map P-R1=>R4
R2(config-route-map)#mat ip add R1=>R4
R2(config-route-map)#set ip next-hop 1.1.23.3
R2(config-route-map)#int s1/0.12
R2(config-subif)#ip policy route-map P-R1=>R4
R2(config-subif)#end
R2#
*Mar  1 00:11:53.759: PR-RP: Set Serial1/0.12 policy_routemap=P-R1=>R4; cached_map=P-R1=>R4
*Mar  1 00:11:53.767: PR-RP: Set Serial1/0.12 policy_routemap=P-R1=>R4; cached_map=P-R1=>R4
*Mar  1 00:12:07.983: IP: s=1.1.1.1 (Serial1/0.12), d=1.1.4.4, len 100, FIB policy match
*Mar  1 00:12:07.983: IP: s=1.1.1.1 (Serial1/0.12), d=1.1.4.4, g=1.1.23.3, len 100, FIB policy routed

2. 일반라우팅을 우선 하고 라우팅테이블 경로가 없을때 PBR 적용하게 하기

R2(config)#route-map P1-R1=>R4
R2(config-route-map)#mat ip add R1=>R4
R2(config-route-map)#set ip default next-hop 1.1.23.3

@@@ R1#ping 1.1.4.4 so 1.1.1.1 re 2 @@@

R2(config-subif)#
*Mar  1 00:21:30.919: IP: s=1.1.1.1 (Serial1/0.12), d=1.1.4.4, len 100, FIB policy match
*Mar  1 00:21:30.919: IP: s=1.1.1.1 (Serial1/0.12), d=1.1.4.4, len 100, FIB policy rejected(explicit route) - normal forwarding

R2(config)#ip prefix-list BAN-R4 deny 1.1.4.0/24
R2(config)#ip prefix-list BAN-R4 permit 0.0.0.0/0 le 32
R2(config)#
R2(config)#router ospf 1
R2(config-router)#distribute-list prefix BAN-R4 in s1/0.23
R2(config-router)#distribute-list prefix BAN-R4 in s1/0.32
R2(config-router)#do sh ip ro ospf
     1.0.0.0/24 is subnetted, 7 subnets
O       1.1.1.0 [110/65] via 1.1.12.1, 00:00:09, Serial1/0.12
O       1.1.3.0 [110/51] via 1.1.32.3, 00:00:09, Serial1/0.32
O       1.1.34.0 [110/114] via 1.1.32.3, 00:00:09, Serial1/0.32

@@@ R1#ping 1.1.4.4 so 1.1.1.1 re 2 @@@

R2(config-router)#
*Mar  1 00:23:21.759: IP: s=1.1.1.1 (Serial1/0.12), d=1.1.4.4, len 100, FIB policy match
*Mar  1 00:23:21.759: IP: s=1.1.1.1 (Serial1/0.12), d=1.1.4.4, g=1.1.23.3, len 100, FIB policy routed

3. PBR 부하분산

R4(config)#int lo 2
R4(config-if)#ip add 2.2.4.4 255.255.255.0
R4(config-if)#ip os ne point-to-p
R4(config-if)#router os 1
R4(config-router)#net 2.2.4.4 0.0.0.0 ar 0

R2(config)#ip access-list extended R1=>R4-2
R2(config-ext-nacl)#permit ip host 1.1.1.1 host 2.2.4.4
R2(config-ext-nacl)#exit
R2(config)#route-map P-LB
R2(config-route-map)#mat ip add R1=>R4
R2(config-route-map)#set ip next-hop 1.1.23.3
R2(config-route-map)#exit
R2(config)#route-map P-LB 20      
R2(config-route-map)#mat ip add R1=>R4-2    
R2(config-route-map)#set ip next-hop 1.1.32.3
R2(config-route-map)#exit
R2(config)#
R2(config)#int s1/0.12
R2(config-subif)#ip policy route-map P-LB

R1#p 1.1.4.4 so lo 0 re 1
*Mar  1 00:32:54.867: IP: s=1.1.1.1 (Serial1/0.12), d=1.1.4.4, len 100, FIB policy match
*Mar  1 00:32:54.867: IP: s=1.1.1.1 (Serial1/0.12), d=1.1.4.4, g=1.1.23.3, len 100, FIB policy routed

R1#p 2.2.4.4 so lo 0 re 1
*Mar  1 00:33:04.675: IP: s=1.1.1.1 (Serial1/0.12), d=2.2.4.4, len 100, FIB policy match
*Mar  1 00:33:04.675: IP: s=1.1.1.1 (Serial1/0.12), d=2.2.4.4, g=1.1.32.3, len 100, FIB policy


출처 : http://light99.egloos.com


Trackback 0 Comment 0