본문 바로가기

SSH Key1

728x90
Cisco 다중 취약점 보안업데이트 개요Cisco NX-OS 제품에 영향을 주는 다중 취약점과 WAAS에서 발생 가능한 원격 실행 코드 실행 취약점을 해결한 보안 업데이트를 발표[1][2]공격자는 영향 받는 시스템에 사용자 권한으로 임의 코드를 실행 및 권한 상승을 할 수 있으므로, 최신버전으로 업데이트 권고Cisco NX-OS 가상 장치 Context SSH 권한 상승 취약점[CVE-2014-2200]Cisco NX-OS 가상 장치 Context SSH Key 권한 상승 취약점[CVE-2013-1191]Cisco NX-OS-Based 제품 스마트 콜 홈 버퍼 오버플로우 취약점[CVE-2014-3261]Cisco NX-OS 메시지 전송 서비스 거부 취약점[CVE-2014-2201]쉐어포인트 가속 기능 구성시 Cisco 광역 어플리케이션 서.. 2014. 5. 26.
728x90

개요

  • Cisco NX-OS 제품에 영향을 주는 다중 취약점과 WAAS에서 발생 가능한 원격 실행 코드 실행 취약점을 해결한 보안 업데이트를 발표[1][2]
  • 공격자는 영향 받는 시스템에 사용자 권한으로 임의 코드를 실행 및 권한 상승을 할 수 있으므로, 최신버전으로 업데이트 권고
    • Cisco NX-OS 가상 장치 Context SSH 권한 상승 취약점[CVE-2014-2200]
    • Cisco NX-OS 가상 장치 Context SSH Key 권한 상승 취약점[CVE-2013-1191]
    • Cisco NX-OS-Based 제품 스마트 콜 홈 버퍼 오버플로우 취약점[CVE-2014-3261]
    • Cisco NX-OS 메시지 전송 서비스 거부 취약점[CVE-2014-2201]
  • 쉐어포인트 가속 기능 구성시 Cisco 광역 어플리케이션 서비스(WAAS) 소프트웨어 5.1.1 ~ 5.1.1d 버전에서 버퍼오버플로우 취약점을 이용한 원격코드 실행이 가능함[CVE-2014-2196]


설명

  • 해당 취약점에 영향 받는 NX-OS 기반 제품은 권한 상승 취약점을 가지고 있음, VDC 환경이 구성된 환경에서 SSH를 이용한 관리자 페이지 접근이 인증된 공격자는 취약점을 악용하여 다른 VDC에서 관리자 권한을 획득할 수 있음 또한 SSH 키 내용 중 로그인 관련 내용을 조작하여 다른 VDC에서 관리자 권한을 획득할 수 있음
  • 스마트 콜 홈 기능을 지원하는 NX-OS 기반 제품은 버퍼 오버플로우 취약점이 존재하여 임의코드 실행이 가능함
  • NX-OS 기반 제품의 메시지 전송 서비스를 이용하여 서비스 거부(DoS) 상태를 유발 할 수 있음


해당 시스템

  • 영향 받는 제품 및 버전(O 표시)


해결 방안

  • 취약점이 발생한 Cisco 소프트웨어가 설치된 Cisco장비의 운영자는, 해당되는 참고사이트에 명시되어 있는 ‘Affected Products’ 및 “Software Versions and Fixes”내용을 확인하여, 패치 적용 


용어 정리

  • VDC (virtual device context) : 네트워크 스위치 가상화 기술
  • 버퍼오버플로우 : 입력값에 대한 길이 검증을 하지 않아 발생되는 취약점


기타 문의사항

  • 한국인터넷진흥원 인터넷침해대응센터: 국번없이 118

 

[참고사이트]

[1] http://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20140521-nxos

[2] http://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20140521-waas

728x90
728x90