'Switch'에 해당되는 글 3건

  1. 2009.03.25 Switch MAC Flooding 공격 방어
  2. 2009.03.11 리눅스 및 윈도우(VMware) Dynamips 활용 NAT 구성 (1)
  3. 2009.01.09 [CISCO] Catalyst Switch간 Port trunking 세팅
2009.03.25 15:45

Switch MAC Flooding 공격 방어

******************************
 Switch MAC Flooding
공격 방어
******************************

! Switch
설정하기
ASW(config)# int fa0/1
ASW(config-if)# switchport mode access
ASW(config-if)# switchport port-security violation protect
ASW(config-if)# switchport port-security maximun 3
ASW(config-if)# switchport port-security
ASW(config-if)# switchport port-security mac-address sticky

 

! Switch에서 특정 Interface 설정 확인하기
ASW# show running-config interface fastethernet 0/1
or
ASW#sh run int fa0/1
Building configuration...

Current configuration : 523 bytes
!
interface FastEthernet0/1
 switchport mode access
 switchport port-security
 switchport port-security maximum 5
 switchport port-security violation protect
 switchport port-security mac-address sticky
 switchport port-security mac-address sticky 000c.2933.a982
 switchport port-security mac-address sticky 000c.29a0.2c18
 switchport port-security mac-address sticky 0040.cac4.40ed
 switchport port-security mac-address sticky 6414.fa00.f02e
 switchport port-security mac-address sticky a232.684e.fff9
 no ip address
end

ASW#

 

! 동적 mac-address-table 보기
ASW# sh mac-a dynamic

! 정적 mac-address-table 보기
ASW# sh mac-a static


! Backtrack Live OS
를 이용한 MAC Flooding 공격하기
Konsole 창에서
# while [ 1 ]
>do
>macof
>done

Trackback 0 Comment 0
2009.03.11 09:48

리눅스 및 윈도우(VMware) Dynamips 활용 NAT 구성

Dynamips를 사용하기 위해서는 반드시 해당 장비의 IOS 이미지가 있어야 합니다.

우분투 기준 apt-get 을 이용 dynamips 를 다운로드 받습니다.


sudo apt-get install dynamips( 이미지에는 대문자 D 인데 소문자 d 로 입력해야 됩니다. )


dynamips 를 실행 시키면 작업영역에 대한 device 파일들이 생성되기 때문에 work 디렉터리를 생성하는 것이 좋습니다.



설정 dynamips에 접속을 위한 dynagen 의 설정파일을 생성 합니다.


(설정파일의 이름은 자신이 쉽게 타이핑 할 수 있는 것으로 합니다.)


아래와 같이 설정 파일을 작성 합니다.


(global section 영역에 autostart를 false로 주는 이유는 장비 이미지를 불러와 로딩시키게 되면 cpu 점유율이 100% 까지 올라가게 되는데 수동으로 장비 하나만을 시작시켜서 이부분에 대한 설정을 하기 위함입니다. - 추후 설명 -)


다이나 밉스 서버를 7200 번 포트로 실행 시킵니다.



종전 만들어 놓은 설정파일을 이용 dynagen 으로 dynamips 서버에 접속 합니다.


(접속한뒤 start R1 명령을 이용 R1 장비를 실행 합니다. R1 은 위에서 설정한 설정파일의 device section 중 ROUTER R1에 해당 합니다.)


실제로 CPU 점유율이 100% 까지 상승 함을 알 수 있습니다.



이부분을 해결하기 위해 dynagen 에서 다음 명령을 입력 합니다


(별표 된 부분의 hex 코드값을 기록해 둡니다. 그리고 별표 옆 숫자를 입력하고 빠져 나옵니다.)


다음 다시 설정 파일을 열어서 idlepc 에 해당하는 옵션 부분을 device section에 추가해 줍니다.
또한, global section에 있던 autostart 부분을 삭제 합니다.


(2691 라우터 장비 모두에 해당 하도록 2691 부분에 idlepc 값을 세팅 합니다.)


다시 dynage을 실행 합니다.


실제로 cpu 점유율이 크게 하락했음을 알 수 있습니다.



라우터로 텔넷을 이용 접속 합니다.


(정상 접속됨을 확인할 수 있습니다.)


접속을 완전히 종료하기 위해서는 Ctrl + ] 키를 누르고 quit 를 입력합니다.



dynamips 서버를 종료하기 위해 pid 값을 찾고 kill 명령을 이용 종료 시킵니다.


------------------------------------------------------------------------------------------------------

Dynamips 는 unbuntu 기준 apt-get install Dynamips 를 이용 받을 수 있으며
설치는 dpkg -i Dynamips 를 이용한다.

man Dynamips 를 이용하면 상세한 도움말을 확인 할 수 있는데.

Dynamips 를 이용 하는 경우 Command line 을 이용 한대의 라우터 서버만을 구동 시킬 수 있다고 설명 되어 있는 것으로 보여 단순 서버(실행 영역)로 사용 하기로 한다.

Dynamips 에서는 이러한 모드를 Hypervisor 모드 라고 하는데 이것은 VMM(Virtual Machine Monitor) 라고 하고 컴퓨터 하드웨어 가상화 소프트웨어로 다중 운영체제를 host 컴퓨터에서 병행 수행 할 수 있게 하는 것을 말한다.
(wiki : A hypervisor, also called virtual machine monitor (VMM), is a computer hardware platform virtualization software that allows multiple operating systems to run on a host computer concurrently.)

여하튼 이것은 라우터 여러대를 하나의 PC 에서 동작할 수 있게 해주는 모드로서 실행하기위해 dynamips 의 -H 옵션을 이용한다.
dynamips -H 7200(default port number)

이렇게 하면 server 프로세스가 띄어지고 dynagen 을 이용하여 router를 생성한뒤 접속을 하기만 하면 된다.

dynagen은 dynamips 에 접속하여 설정에 따라 실제 IOS 이미지를 읽어  라우터의 갯수만큼 가상 라우터를 부팅 시켜 준다.

이 것을 하기 위해 설정 파일의 작성이 필요하다.

빈줄 이나 '#' 으로 시작하는 라인은 무시된다(주석)
dynagen 설정 파일에는 3개의 섹션이 존재 한다.
Global section, Server section, Device section

Global section 과 Server section 의 경우 [...] 으로 시작되며
Device section 의 경우 [[...]] 으로 시작된다.
Server section 과 Device section 은 여러개 구성할 수 있다.

Server Section : [<ip-address | hstname>] ex) [127.0.0.1] or [localhost]
Device Section : [[7200 | ROUTER | FRSW | ATMSW | ETHSW <name>]]
7200섹션에 명시된 설정들은 다이다밉스 서버의 모든 7200 라우터에 기본설정으로 적용 된다.

Global section
 autostart 옵션이 들어갈 수 있는데 이것은 dynagen이 dynamips에 접속하는 순간 모든 라우터들을 실행 시키라는 것으로 기본 설정은 True 이다.
또한 이 옵션은 dynagen 으로 접속한뒤 "start /all" 을 입력하는 것과 같은 행동을 한다.

Server section

port <1-65535> (default: 7200)
서버에 접속하기 위한 포트 설정 부분으로 기본은 7200 이다. (Hypervision port to connect to.)

workingdir <path> (default: None)
 dynamips을 구동시키면 여러가지 네트워크를 위한 디바이스 파일들이 생성 되는데 이것들을 위한 저장소 위치를 full path 로 입력 한다. 

console <1-65535> (default: 2000)
 기본 콘솔 접속 포트번호로서 새로운 장비를 설정 한뒤 콘솔 포트번호를 명시 하지 않으면 기존 장비의 마지막 포트번호 + 1 이 콘솔 포트로서 지정되며, 첫번째 장비의 기본 포트번호는 2000번 이다.

udp <1-65535> (Default: 10000)
 NIOs를 위한 기본 UDP 포트 설정(Set the base UDP port for NIOs.)

Device 설정은

[[7200]]
 7200 섹션은 다이나밉스 서버의 모든 7200 라우터 들에 대한 기본 설정이다.
 
image <path/file> (Default: None)
 다이나밉스가 동장하는 시스템의 7200 IOS 이미지가 존재하는 full path를 입력 한다.
 7200 IOS 이미지 파일의 전체 path.

ram <integer> (Default: None)
 모든 7200 라우터들에 대한 메모리 할당량을 적는다.

rom <integer> (Default: None)
 Rom size

nvram <integer> (Default: None)
 NVRAM size

disk0 <integer> (Default: None)
  Set size of PCMCIA ATA disk0
disk1 <integer> (Default: None)
  Set size of PCMCIA ATA disk1

cnfg <path/file> (Default: None)
 다이나밉스가 동작중인 시스템의 설정파일 full path를 입력한다.

confreg <hex> (Default: 0x2102)
 Configure Register 값 설정

idlepc <string> (Default: None)
 Idle PC 값 설정.  (Idle PC값 설정에 관해서는 뒤에 설명)


exec_area <string> (Default: None)
 Set the exec area size.
clock <integer> (Default: None)
 Clock divisor (should no longer been needed as of dynamips 0.2.5 RC1)
npe <npe-100|150|175|200|225|300|400> (Default: None)
 NPE type.
midplane <std|vxr> (Default: None)
 Midplane, either "std" or "vxr"
mmap <binary> (Default: True)
 Set to false to use real memory rather  than  a  disk  file  for router  vitural  memory. Conserves RAM at the expense of perfor‐mance.

[[ROUTER <name>]]
 라우터의 이름은 중복되지 않게 한다.

model 7200 (Default: 7200)
 사용할 라우터의 모델번호를 적는다.

console <1-65535> (default: None)
 라우터에 접속을 위한 콘솔포트 번호.
 기본값은 서버섹션에 명시된 콘솔포트 번호가 첫번째 장비에 설정되며,
 새로운 장비를 설정 한뒤 콘솔 포트번호를 명시 하지 않으면 기존 장비의 마지막
 포트번호 + 1 이 콘솔 포트로서 지정되며, 첫번째 장비의 기본 포트번호는 2000번 이다.

aux <1-65535> (default: None)
 aux 포트

slotX  <0-X> <슬롯에 꼽을 모듈 타입들> (default: None)
 slot번호 모듈
옵션으로 설정하지 않으면 기본적인 인터페이스들이 dynagen에 의해서 만들어짐.

 slot0 = PA-C7200-IO-FE        #Ethernet in slot 0
 slot1 = PA-FE-TX        #Ethernet in slot 1
 slot3 = PA-4T            #PA-4T+ in slot2
 slot6 = PA-4E            #PA-4E in slot 6
 #slotx = PA-POS-OC3        #PA-POS-OC3 in slot x

이 부분의 경우 각 장비에 사용될 수 있는 모듈 모델명을 알고 있어야 할 듯.

<local interface> = <remote interface>
 인터페이스에 대한 명시(각 인터페이스간 연결 구성)
 f1/0 = R2 f1/0        #Connect to f1/0 on device R2
 f2/0 = LAN 1        #Connect to bridged LAN 1
 s3/0 = R2 s3/0        #Connect to s3/0 on device R2
 s3/0 = F1 1        #Connect to port 1 on device "F1" (a frame relay switch)
 s3/1  =  F1  1         # Connect to port 1 on device "F1" (a frame relay switch)
 s3/2 = F2 1
 a4/0 = A1 1         # Connect to port 1 on device  "A1"  (an ATM switch)
 f5/0 = NIO_linux_eth:eth0   # manually specify an NIO

 [[ROUTER R2]]
 # f1/0 인터페이스는 R1 의 설정을 참조하여 자동으로 만들어 진다.
 # s3/0 의 경우도 동일
 f2/0 = LAN 1        # Connect to bridged LAN 1
 s4/0 = F1 2
 s4/1 = F2 2
 s4/2 = F1 3
 a5/0 = A1 2

 [[router R3]]       # Case is not significant
  # Examples of other manually specified NIOs
 f1/0          =           NIO_gen_eth:\Device\NPF_{B00A38DD-
 F10B-43B4-99F4-B4A078484487}
 f2/0 = NIO_udp:10000:172.0.0.1:10001
 f3/0 = NIO_tap:tap0
 f4/0 = NIO_unix:/tmp/local:/tmp/remote
 f5/0 = NIO_vde:foo:bar

 [[ETHSW <name>]]
  Define an Ethernet Switch
 [[ETHSW S1]]
  1 = access 1        # Port 1 is an access port in vlan 1
  2 = access 20       # Port 2 is an access port in vlan 20
  3 = dot1q 1         # Port 3 is a trunk port (dot1q encapsu‐lation) with native vlan 1
  4 = dot1q 1  NIO_gen_eth:eth0    #  Port  4  is  trunk  port
  (naitive  vlan  1)  that  is  connected to the host eth0 via the gen_eth NIO
  #4    =    dot1q    1     NIO_gen_eth:\Device\NPF_{B00A38DD-F10B-43B4-99F4-B4A078484487} # Same as above, Windows example

 [[FRSW <name>]]
   Each FRSW section defines a frame relay switch. All keywords are optional
   1:102 = 2:201      # Tell the FRSW to switch  from  port  1,DLCI 102 to port 2, DLCI 201.
   1:103  =  3:301       # and from port 1, DLCI 103 to port 3, DLCI 301

 [[FRSW F2]]
  1:102 = 2:201

 [[ATMSW <name>]]
  Deine an ATM Switch
  1:10 = 2:20         # Port 1, vpi 10 to port 2, vpi 20
  #1:10:200 = 2:20:100 # Port 1, vpi 10, vci 200  to  port  2,
  vpi 20, vci 100

EXAMPLES
       See /usr/share/doc/dynagen/examples directory

------------------------------------------------------------------------------------------------------

DYNAGEN(1)                                                          DYNAGEN(1)


NAME
       dynagen - command line interface to dynamips Cisco 7200 Emulator

SYNOPSIS
       dynagen [options] configuration file

DESCRIPTION
       Dynagen  is a text-based front end for Dynamips, that uses the hypervi‐
       sor mode for communication with Dynamips. Dynagen  simplifies  building
       and  working  with  virtual networks. Dynagen uses a simple and easy to
       understand configuration file for specifying  virtual  router  hardware
       configurations.  Configuration  file  has a simple syntax for intercon‐
       necting routers, bridges, frame-relay and ATM switches. No need to deal
       with  NetIO’s.  Dynagen  provides a management CLI for listing devices,
       starting, stopping, reloading, suspending and resuming virtual routers.
       Dynagen  can work in a client server mode, with dynagen running on your
       Workstation communicating to  dynamips  servers  running  ona  back-end
       server.  Dynagen  can also control multiple dynamips servers simultane‐
       ously for distributing large virtual networks across several  machines.

       Before running dynagen you need to start dynamips:

       nice dynamips -H 7200 &


OPTIONS
       This  program  follow  the  usual  GNU  command  line syntax, with long
       options starting with  two  dashes  (‘-’).  A  summary  of  options  is
       included below.

       -n, --nosend
              Do not send any command to dynamips.

       -d, --debug
              Show debugging information.

       -h, --help
              Show summary of options.

       --version
              Show version.

CONFIGURATION FILE OPTIONS
       Empty lines or lines starting with a hash (’#’) are ignored.
       Configuration  file,  in  other documentation also called network file,
       knows three sections: global section, server section which starts  with
       [...]   and device section which start with [[...]]. Server section and
       device section can have multiple occurrencies.

       Server Section: [<ip-address|hostname>]
       Device Section: [[7200|ROUTER|FRSW|ATMSW|ETHSW <name>]] The  7200  sec‐
       tion  specifies  defaults for all 7200 routers on this Dynamips server.
       Everything in this section is optional, and defaults  to  whatever  the
       default is in Dynamips

       Global Configuration variable
              autostart <true/false> (Default: True)
              By  default, all routers are automatically started when a lab is
              launched. The autostart keyword overrides this behavior, and the
              lab must manually be started (start /all).

       Server Configuration variables
              port <1-65535> (Default: 7200)
              Hypervision port to connect to.
              workingdir <path> (Default: None)
              Set the directory where Dynamips will store all the device files
              for this network. This is the fully qualified path  relative  to
              the system running dynamips.
              console <1-65535> (Default: 2000)
              Base  console  port. New instances that do not specify a console
              port will default to this + the instance number.
              udp <1-65535> (Default: 10000)
              Set the base UDP port for NIOs.

       Device Configuration variables

       [[7200]]
              The 7200 section specifies defaults for all 7200 routers on this
              Dynamips  server.  Everything  in  this section is optional, and
              defaults to whatever the default is in Dynamips.

              image <path/file> (Default: None)
              Full path to 7200 IOS image file. This is  the  fully  qualified
              path relative to the system running dynamips.
              ram  <integer> (Default: None) Amount of Virtual RAM to allocate
              to each router instance.
              rom <integer> (Default: None)
              Size of ROM.
              nvram <integer> (Default: None)
              Size of NVRAM.
              disk0 <integer> (Default: None)
              Set size of PCMCIA ATA disk0
              disk1 <integer> (Default: None)
              Set size of PCMCIA ATA disk1
              cnfg <path/file> (Default: None)
              Configuration file to import. This is the fully  qualified  path
              relative to the system running dynamips.
              confreg <hex> (Default: 0x2102) 0x210X where X=0,1,2
              Set the configuration register
              idlepc <string> (Default: None)
              Set the Idle PC value.  Include a description here.
              exec_area <string> (Default: None)
              Set the exec area size.
              clock <integer> (Default: None)
              Clock divisor (should no longer been needed as of dynamips 0.2.5
              RC1)
              npe <npe-100|150|175|200|225|300|400> (Default: None)
              NPE type.
              midplane <std|vxr> (Default: None)
              Midplane, either "std" or "vxr"
              mmap <binary> (Default: True)
              Set to false to use real memory rather  than  a  disk  file  for
              router  vitural  memory. Conserves RAM at the expense of perfor‐
              mance.

       [[ROUTER <name>]]
              All options from the 7200 section  are  options  here  as  well,
              including "autostart". <name> must be unique in network file.
              model 7200 (Default: 7200)
              console <1-65535> (Default: None)
              Console port. Defaults to the server’s base console port (speci‐
              fied in the server section) + instance number.
              aux <1-65535> (Default: None)
              Aux port.
              slotX   <0-X>   <PA-C7200-IO-FE|PA-FE-TX|PA-4T|PA-4E|PA-POS-OC3>
              (Default: None)
              Manual PA specification. This is optional, and if not done dyna‐
              gen will make sane decisions based on the  interface  specifica‐
              tions.
                  slot0 = PA-C7200-IO-FE  # Ethernet in slot 0
                  slot1 = PA-FE-TX        # Ethernet in slot 1
                  slot3 = PA-4T           # PA-4T+ in slot 2
                  slot6 = PA-4E           # PA-4E in slot 6
                  #slotx = PA-POS-OC3     # PA-POS-OC3 in slot x

              <local interface> = <remote interface>
              Interface specification. Can take the following forms:
                  f1/0 = R2 f1/0      # Connect to f1/0 on device R2
                  f2/0 = LAN 1        # Connect to bridged LAN 1
                  s3/0 = R2 s3/0      # Connect to s3/0 on device R2
                  s3/1  =  F1  1         # Connect to port 1 on device "F1" (a
              frame relay switch)
                  s3/2 = F2 1
                  a4/0 = A1 1         # Connect to port 1 on device  "A1"  (an
              ATM switch)
                  f5/0 = NIO_linux_eth:eth0   # manually specify an NIO

                  [[ROUTER R2]]
                  #  Interface  f1/0 will automatically be created because the
              interface was referenced in R1’s config
                  f2/0 = LAN 1        # Connect to bridged LAN 1
                  s4/0 = F1 2
                  s4/1 = F2 2
                  s4/2 = F1 3
                  a5/0 = A1 2

                  [[router R3]]       # Case is not significant
                  # Examples of other manually specified NIOs
                  f1/0          =           NIO_gen_eth:\Device\NPF_{B00A38DD-
              F10B-43B4-99F4-B4A078484487}
                  f2/0 = NIO_udp:10000:172.0.0.1:10001
                  f3/0 = NIO_tap:tap0
                  f4/0 = NIO_unix:/tmp/local:/tmp/remote
                  f5/0 = NIO_vde:foo:bar

       [[ETHSW <name>]]
              Define an Ethernet Switch
                  [[ETHSW S1]]
                  1 = access 1        # Port 1 is an access port in vlan 1
                  2 = access 20       # Port 2 is an access port in vlan 20
                  3 = dot1q 1         # Port 3 is a trunk port (dot1q encapsu‐
              lation) with native vlan 1
                  4 = dot1q 1  NIO_gen_eth:eth0    #  Port  4  is  trunk  port
              (naitive  vlan  1)  that  is  connected to the host eth0 via the
              gen_eth NIO
                  #4    =    dot1q    1     NIO_gen_eth:\Device\NPF_{B00A38DD-
              F10B-43B4-99F4-B4A078484487} # Same as above, Windows example

       [[FRSW <name>]]
              Each FRSW section defines a frame relay switch. All keywords are
              optional
                  1:102 = 2:201      # Tell the FRSW to switch  from  port  1,
              DLCI 102 to port 2, DLCI 201.
                  1:103  =  3:301       # and from port 1, DLCI 103 to port 3,
              DLCI 301

                  [[FRSW F2]]
                  1:102 = 2:201


       [[ATMSW <name>]]
              Define an ATM Switch
                  1:10 = 2:20         # Port 1, vpi 10 to port 2, vpi 20
                  #1:10:200 = 2:20:100 # Port 1, vpi 10, vci 200  to  port  2,
              vpi 20, vci 100


EXAMPLES
       See /usr/share/doc/dynagen/examples directory

BUGS
       Take a look at the Bug tracking system.

REPORTING BUGS
       Please send bug reports to http://www.ipflow.utc.fr/bts/

SEE ALSO
       http://www.ipflow.utc.fr/index.php/
       http://www.ipflow.utc.fr/blog/
       http://dyna-gen.sourceforge.net/
       http://hacki.at/7200emu/index.php

AUTHOR
       dynagen was written by Greg Anuzelli (dynagen@gmail.com)
       This  manual  page was written by Erik Wenzel <erik@debian.org> for the
       Debian GNU/Linux system (but may be used by others).



                                 Aug 29, 2006                       DYNAGEN(1)



 

목표 : Dynamips 와 VMware 를 이용하여서 PC1대로 위 기능을 실제처럼 Test...

간단 구성도

인터넷------port1[IP공유기]port2---eth0[PC1] 192.168.0.3
                                       port3---eth0[PC2] 192.168.0.4

저희 집 구성도 이며 IP공유기를 사용하고 있고 PC1의 IP는 192.168.0.3(사설IP)입니다. 

물론 유동 IP입니다. 한 2주정도에 한번씩 바뀌는것 같더군요...

IP공유기쪽 사설 IP는 당근 192.168.0.1 입니다.  "유동ip-port1[공유기-192.168.0.1]"

-------------- xxx.net 파일 입니다-------------------

[[ROUTER r1]]
model = 3660
f0/0 = sw1 2  
f1/0 = NIO_gen_eth:\Device\NPF_{756AEFA5-654A-408A-B49E-573A45827371} ## Vmnet1
f2/0 = NIO_gen_eth:\Device\NPF_{643C727A-2636-4F93-820B-1F35D6698FB1} ## Vmnet8

[[ETHSW sw1]]
1 = access 1 NIO_gen_eth:\Device\NPF_{D15FB207-D063-454D-BCF8-ABC92AA31800} ## Real Nic
2 = access 1

----------------------------------------------

그럼 이제 실습을 위한 논리적 구성도입니다.

인터넷-----[IP공유기]---dynamips[가상스위치]---eth0[PC1]
                                                                   ---f0/0[가상라우터]f1/0--vmnet1--eth0[가상PC1]
                                                                                               f2/0--vmnet8--eth0[가상PC2]


* dynamips[가상스위치sw1]---eth0[PC1]
                                        ---f0/0[가상라우터] 

위 부분을 살펴 봅니다. PC1은 현재 IP가 192.168.0.3 을 사용하고 있으며 가상라우터는 192.168.0.11 을 설정하였습니다.(ping 168.126.63.1 성공) 

 

 

                                   [ interface FastEthernet0/0     ==> 가상라우터에 설정
                                       ip address 192.168.0.11 255.255.255.0
                                       !
                                      ip route 0.0.0.0 0.0.0.0 192.168.0.1 permanent ]

 

* [가상라우터]f1/0----VMnet1---eth0[가상PC1]

   이 부분은 가상라우터의 f1/0 과 VMware 의 가상 호스트 즉, 가상컴퓨터의 랜카드와 연동.

   VMnet1 은 Host-only 로서 기본적으로 인터넷을 사용할 수 없습니다.

 

 

" f1/0 = NIO_gen_eth:\Device\NPF_{756AEFA5-654A-408A-B49E-573A45827371} ## Vmnet1 "

 

==============

==============

가상라우터의 f1/0 에 10.1.1.1 을 넣고 연결된 가상PC에 10.1.1.2 를 넣습니다.

이후 서로간에 ping 확인


 

그럼 일단 가상라우터에 NTP 서버로 시간을 실제 현 시간과 동기화를 시켜 보겠습니다.

 

Sola99R(config)#ip name-server 168.126.63.1
Sola99R(config)#clock timezone KOR +9
Sola99R(config)#ntp server ntp.ewha.net 

 

 

==========================

 

2 번째로 NAT를 사용해서 가상 호스트가 인터넷이 되도록 하겠습니다...

 

현재 가상라우터까지는 인터넷이 잘 됩니다. 이제 그 아래 10.1.1.0/24 네트워크도 NAT 기능을

 

이용하여서 인터넷이 되도록 설정하겠습니다...

 

-------------- 가상라우터 cfg--------------

interface FastEthernet0/0
 ip address 192.168.0.11 255.255.255.0
 ip nat outside
!
interface FastEthernet1/0
 ip address 10.1.1.1 255.255.255.0
 ip nat inside
!
ip nat inside source list INSIDE interface FastEthernet0/0 overload
!
ip access-list standard INSIDE
 permit 10.1.1.0 0.0.0.255

==========================================

 

 

이상으로 1대 컴퓨터를 사용한 NTP, NAT 실습을 알아 보았습니다...

 

첨부파일로 실습에 사용할 수 있는 xxx.net 파일과 라우터 cfg 파일 입니다.


==========

autostart = False

[192.168.0.3]
workingdir = D:\Lab\ccie\working

[[3660]]
image = D:\Data\cisco\ios-dynamips\unzip-c3660-ik9o3s-mz[1].124-6.T.bin
ram = 128
idlepc = 0x606f4394

[[ROUTER r1]]
model = 3660
f0/0 = sw1 2
f1/0 = NIO_gen_eth:\Device\NPF_{756AEFA5-654A-408A-B49E-573A45827371} ## Vmnet1
f2/0 = NIO_gen_eth:\Device\NPF_{643C727A-2636-4F93-820B-1F35D6698FB1} ## Vmnet8

[[ETHSW sw1]]
1 = access 1 NIO_gen_eth:\Device\NPF_{D15FB207-D063-454D-BCF8-ABC92AA31800} ## Real Nic
2 = access 1

================= 

!
! Last configuration change at 21:07:16 KOR Mon Aug 13 2007
! NVRAM config last updated at 21:13:56 KOR Mon Aug 13 2007
!
version 12.4
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
no service password-encryption
!
hostname Sola99R
!
boot-start-marker
boot-end-marker
!
logging buffered 8192 debugging
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
clock timezone KOR 9
!
!
ip cef
ip name-server 168.126.63.1
!
!
!
interface FastEthernet0/0
 ip address 192.168.0.11 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.1.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 192.168.0.1 permanent
!
ip nat inside source list INSIDE interface FastEthernet0/0 overload
!
!
ip access-list standard INSIDE
 permit 10.1.1.0 0.0.0.255
!
!
!
control-plane
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
ntp clock-period 17180026
ntp server 211.189.50.33
!
end


Trackback 0 Comment 1
  1. cisco blog 2009.03.11 20:40 address edit & del reply

    Cisco 7200 Simulator
    http://www.ipflow.utc.fr/blog/

    http://unixgeek.wordpress.com/category/cisco/

2009.01.09 16:09

[CISCO] Catalyst Switch간 Port trunking 세팅

Network Diagram

구 성 들

Catalyst 3512-XL

주 석: 다음의 스크린 캡쳐는 3512XL 스위치에서 사용한 명령어를 보여주고 있다. 명령어와 명령어 사이의 파란색 이탤리체는 명령어와 절차를 설명하기 위한것이다.
!-- privileged 모드로 진입
!-- 스위치에 TELNET 패스워드 설정
.
switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
switch(config)#hostname 3512xl
3512xl(config)#enable password mysecret
3512xl(config)#line vty 0 4
3512xl(config-line)#login
3512xl(config-line)#password mysecret
3512xl(config-line)#exit
3512xl(config)#no logging console
3512xl(config)#^Z
!--VLAN 1의 IP 와default gateway는 관리 목적을 위한 것이다.
3512xl#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
3512xl(config)#int vlan 1
3512xl(config-if)#ip address 10.10.10.2 255.255.255.0
3512xl(config-if)#exit
3512xl(config)#ip default-gateway 10.10.10.1
3512xl(config)#end
!-- Set the VTP Mode.
!-- 우리 예제에서는 VTP TRANSPARENT 모드로 셋팅 하였다.
!-- VTP 모드로 셋팅에 관한것은 여러분의 네트워크에 달려있다.
!-- 보다 자세한 VTP에 관해서는
!-- 다음의
!-- Configuring VTP, VLANs, and VLAN Trunks on Catalyst 2900XL and 3500XL Switches
를 참고하라.
3512xl#vlan database 3512xl(vlan)#vtp transparent Setting device to VTP TRANSPARENT mode. !-- 디폴터 상태의 VLAN1에 VLAN2 추가. 3512xl(vlan)#vlan 2 VLAN 2 added: Name: VLAN0002 3512xl(vlan)#exit APPLY completed. Exiting.... !-- FASTETERNET 0/1에 트렁킹 활성화. 3512xl#configure terminal Enter configuration commands, one per line. End with CNTL/Z. 3512xl(config)#int fastEthernet 0/1 3512xl(config-if)#switchport mode trunk !-- 트렁킹 encapsulation 중에 isl로 활성화 3512xl(config-if)#switchport trunk encapsulation isl !-- 혹은 dot1q을 설정: 3512xl(config-if)#switchport trunk encapsulation dot1q !-- dot1q의 경우에, 링크 반대편이 NATIVE VLAN !-- 인지 확인할 필요가 있다. !-- 3512XL은, 디폴터로 native VLAN은 1 이다. !-- 당신의 네트웍의 필요에 따라 VLAN1의 NATIVE VLAN !-- 을 바꿀수 있다. !-- 그러나 라우터에 따라 NATIVE VLAN을 바꾸는 것은 !-- 매우 중요한 것이다. !-- 필용에 의해 다음의 명령어를 사용하여 NATIVE VLAN을 바꿀수 있다: !-- 3512xl(config-if)#switchport trunk native vlan !-- 트렁크상에서 모든 VLAN들을 수용한다. 3512xl(config-if)#switchport trunk allowed vlan all 3512xl(config-if)#exit !-- 다음 명령어의 설정으로 FastEthernet 0/2은 !-- VLAN2로 옮겨가고 portfast가 인터페이스 상에 활성화 된다. 3512xl(config)#int fastEthernet 0/2 3512xl(config-if)#switchport access vlan 2 3512xl(config-if)#spanning-tree portfast 3512xl(config-if)#exit !-- FastEthernet 0/3은 이미 디폴터로 VLAN1에 있다. !-- 인터페이스 상의 portfast 활성화. 3512xl(config)#int fastEthernet 0/3 3512xl(config-if)#spanning-tree portfast 3512xl(config-if)#^Z !-- 왜 PORTFAST를 활성화 하는지 자세한 사항은 !-- 다음을 참조하라: !-- Using Portfast and Other Commands to Fix Workstation Startup Connectivity Delays .!-- 저장하는 것을 잊지 말아라. 3512xl#write memory Building configuration... 3512xl#

3512xl#show running-config
Building configuration...

Current configuration:

!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3512xl
!
no logging console
enable password mysecret
!
!
!
!
!
ip subnet-zero
!
!
!
interface FastEthernet0/1
  switchport mode trunk
!
!-- 대신에 인터페이스 FASTETHERNET 0/1이
!-- 만약 802.1Q로 구성 되었다면,
!-- 아래와 같이 볼수 있을 것이다:
!-- interface FastEthernet0/1
!-- switchport trunk encapsulation dot1q
!-- switchport mode trunk
!
interface FastEthernet0/2
 switchport access vlan 2
 spanning-tree portfast
!
interface FastEthernet0/3
 spanning-tree portfast
!
interface FastEthernet0/4
!
중간 생략
!
interface FastEthernet0/12
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface VLAN1
 ip address 10.10.10.2 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
!
ip default-gateway 10.10.10.1
!
line con 0
 transport input none
 stopbits 1
line vty 0 4
 password mysecret
 login
line vty 5 15
 login
!
end

Cisco 2600 Router

주 석:다음의 스크린 캡쳐는 2600 라우터에서 사용한 명령어를 보여주고 있다. 명령어와 명령어 사이의 파란색 이탤리체는 명령어와 절차를 설명하기 위한것이다.
!-- privileged 모드로 진입
!-- 라우터에 TELNET 패스워드 설정.
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname c2600

c2600(config)#enable password mysecret
c2600(config)#line vty 0 4
c2600(config-line)#login
c2600(config-line)#password mysecret
c2600(config-line)#exit
c2600(config)#no logging console
c2600(config)#^Z

c2600#configure terminal 상태에서
라인마다 명령어를 설정하고 CNTL/Z을 사용하여 빠진다.

!-- 트렁크 구성을 위하여 FastEthernet 0/0 을 선택한다.
!-- 여기서 진행된것은 L2 도 Layer 3 (L3) 구성도 아니다.
c2600(config)#int fastEthernet 0/0
c2600(config-if)#no shut
c2600(config-if)#exit

!-- 서브 인터페이스 FastEthernet 0/0.1 상에 트렁킹 설정.
!-- 서브 인터페이스 상에 실제의 트렁킹을 구성을 지정.
c2600(config)#int fastEthernet 0/0.1

!-- 트렁킹 Encapsulation중 isl을 설정
c2600(config-subif)#encapsulation isl 1

!-- 혹은dot1q로 설정:
!-- dot1q의 경우에, 링크 반대편이 NATIVE VLAN
!-- 인지 확인할 필요가 있다.
!-- 3512XL은, 디폴터로 native VLAN은 1 이다.
!-- 라우터상에 NATIVE VLAN으로 VLAN1으로 설정.
c2600(config-subif)#encapsulation dot1Q 1 ?
  native  Make this is native vlan
  
c2600(config-subif)#encapsulation dot1Q 1 native
!-- 만약 스위치에서 VLAN1이 아닌 다른 NATIVE VLAN 이라면,
!-- 위의 명령을 사용 하여
!--라우터에서 같은 VLAN으로 NATIVE VLAN을 설정하여 주어야 한다.

주 석: encapsulation dot1Q 1 native 명렁어는 Cisco IOS version 12.1(3)T에서 추가 되었다. 만약 이것보다 이전 버전의 Cisco IOS라면, 라우터에 802.1Q 트렁킹를 구성하기 위해 다음의 801.1Q configuration for Cisco IOS Versions Earlier than 12.1(3)T 부분을 참조하라.
!-- Configure L3 information on the sub-interface 0/0.1.
c2600(config-subif)#ip address 10.10.10.1 255.255.255.0
c2600(config-subif)#exit

!-- FastEthernet 0/0.2 sub-interface에 트렁킹 설정.
!-- sub-interfaces상에 실제 트렁킹 구성예.
c2600(config)#int fastEthernet 0/0.2

!-- encapsulation isl로 트렁킹 설정
c2600(config-subif)#encapsulation isl 2

!-- dot1q 설정:
c2600(config-subif)#encapsulation dot1Q 2

!-- sub-interface 0/0.2에 L3 정보(IP) 설정.
c2600(config-subif)#ip address 10.10.11.1 255.255.255.0
c2600(config-subif)#exit
c2600(config)#^Z

!-- 저장하기.
c2600#write memory
Building configuration...
[OK]
c2600#

주 석: 이 설정이 동작하도록 만들고 워크 스테이션1과 워크스테이션2 사이에 ping이 완전하게 이루어지기 위해서는 워크스테이션의 디폴터 게이터웨이가 정확히 설정 될 필요가 있다.workstation1의 디폴터 게이터웨이는 10.10.11.1 이고 workstation2의 의 디폴터 게이터웨이는 10.10.10.1 이어야 한다.

다음의 것들은 단지 소프트웨어적인것 뿐이다.만약 라우터와 스위치 사이에 802.1Q 트렁킹을 설정 하였고, 위에서의 절차를 따랐서 구성 하였어도 VLAN간 PING이 되지 않 는 다면 BUG NABIGATOR TOOL을 사용하여 확인 하여야 한다. Bug Navigator에 대한 보다 많은 정보를 보려면, Tools Information 부분을 보아라.


c2600#show running-config
Building configuration...
 
Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname c2600
!
no logging console
enable password mysecret
!
!
!
!
!
ip subnet-zero
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 encapsulation isl 1
 ip address 10.10.10.1 255.255.255.0
 no ip redirects
!
!-- 만약 802.1Q 로 구성하면
!--FastEthernet0/0.1 인터페이스상에서
아래와 같이 볼수 있을 것이다:
!-- interface FastEthernet0/0.1
!-- encapsulation dot1Q 1 native
!-- ip address 10.10.10.1 255.255.255.0
!
!
interface FastEthernet0/0.2
 encapsulation isl 2
 ip address 10.10.11.1 255.255.255.0
 no ip redirects
!
!-- 만약 802.1Q 로 구성하면
!--FastEthernet0/0.2 인터페이스상에서
아래와 같이 볼수 있을 것이다:
!-- interface FastEthernet0/0.2
!-- encapsulation dot1Q 2
!-- ip address 10.10.11.1 255.255.255.0
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip classless
no ip http server
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password mysecret
 login
!
no scheduler allocate
end

Cisco IOS 12.1(3)T보다 이전 버전의 라우터에서 801.1Q 구성하기

이 문서의 앞에서 설명 하였듯이, 802.1Q 트렁킹을 구성할때 링크 양쪽이 native VLAN 으로 일치 하는 것은 매우 중요하다.Cisco IOS 버전이12.1(3)T 이전일때,서브 인터페이스아래 명령어가 불가능 하므로 encapsulation dot1Q 1 native와 같이 NATIVE VLAN을 설정 할수가 없다.

이전의 Cisco IOS 버전에서는 SUB-INTERFACE로 VLAN1을 설정하지 않는것이 중요하다. VLAN1상의 라우터는 tag dot1q 프레임을 사용하고 스위치는 tag 되지 않은것을 사용한다. 결과적으로 스위치와 라우터상의 VLAN1을 통하여 트래픽을 보낼수가 없다.

현재의 lab 구성상에서는 다음의 절차에 의해서 Cisco 2600 라우터를 구성 하였다:

!-- privileged 모드로 진입
!-- 라우터에 텔넷 패스워드 설정
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname c2600
c2600(config)#enable password mysecret
c2600(config)#line vty 0 4
c2600(config-line)#login;
c2600(config-line)#password mysecret
c2600(config-line)#exit
c2600(config)#no logging console
c2600(config)#^Z

c2600#configure terminal

!-- 트렁킹 구성을 위한 FastEthernet 0/0 선택
c2600(config)#int fastEthernet 0/0
c2600(config-if)#no shut

!-- 메인 인터페이스에 VLAN1에 IP ADDRESS가 설정 되었다.
!-- 그리고 서브 인터페이스에는 VLAN1을 위한 encapsulation을 설정 하지 않는다.
c2600(config-if)#ip address 10.10.10.1 255.255.255.0
c2600(config-if)#exit

!-- 서브 인터페이스 fastEthernet 0/0.2상에
!-- VLAN2 dot1q encapsulation 설정

c2600(config)#int fastEthernet 0/0.2
c2600(config-subif)#encapsulation dot1Q 2
c2600(config-subif)#

!-- Configuring L3 information on the sub-interface 0/0.2.
c2600(config-subif)#ip address 10.10.11.1 255.255.255.0
c2600(config-subif)#exit
c2600(config)#^Z


!-- 구성 저장
c2600#write memory
Building configuration...
[OK]
c2600#
c2600#show running-config
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname c2600
!
no logging console
enable password mysecret
!
!
!
!
!
memory-size iomem 7
ip subnet-zero
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.10.10.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/0.2
 encapsulation dot1Q 2
 ip address 10.10.11.1 255.255.255.0
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip classless
no ip http server
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password mysecret
 login
!
no scheduler allocate
end

c2600#

debug and show Commands

Catalyst 2900XL/3500XL 상에서는 다음의 명령어를 사용한다:

  • show int {FastEthernet | GigabitEthernet} switchport

  • show vlan

  • show vtp status

On the Cisco 2600 router, use the following commands:

  • show vlan

  • show interface

Sample show Command Output

Catalyst 3500XL Switch

show int {FastEthernet | GigabitEthernet} switchport

이 명령어는 PORT의 설정과 운용 상태를 확인하기 위해 사용한다. 트렁크 양쪽 모두 NATIVE VLAN으로 일치하는지 확인할때도 역시 사용한다. 포트가 802.1Q 트렁킹 모드일때 NATIVE VLAN이UNTAGGED로 사용된다. 보다 자세한 내용은Configuring VTP, VLANs, and VLAN Trunks on Catalyst 2900XL and 3500XL Switches을 참조하라.

3512xl#show int fastEthernet 0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,2
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none

주 석: 802.1Q 트렁키을 위해서 위의 명령어가 아래와 같이 바뀌었다.

3512xl#show int fastEthernet 0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,2
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none

show vlan

이 명령어는 각 인터페이스(포트)들이 정확한 VLAN에 속했는지 확인하기 위하여 사용된다.예제에서는 Fa0/2 인터페이스만이 VLAN2 속한다.그 나머지들은 VLAN1에 속한다..

3512xl#show vlan
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/3, Fa0/4, Fa0/5, Fa0/6,
                                                Fa0/7, Fa0/8, Fa0/9, Fa0/10,
                                                Fa0/11, Fa0/12, Gi0/1, Gi0/2
2    VLAN0002                         active    Fa0/2
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active    

...(output suppressed)

show vtp status

이 명령어는 스위치의 VLAN 트렁킹 프로토콜을 확인하기 위하여 사용된다.This command is used to check the VLAN trunking protocol (VTP) configuration 예제에서는 transparent mode를 사용 하였다.정확한 VTP 모드는 네트워크의 토폴로지에 달려 있다. 보다 자세한 VTP에 대해서는 Configuring VTP, VLANs, and VLAN Trunks on Catalyst 2900XL and 3500XL Switches를 참조하라.

3512xl#show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 254
Number of existing VLANs        : 6
VTP Operating Mode              : Transparent
VTP Domain Name                 : 
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0xC3 0x71 0xF9 0x77 0x2B 0xAC 0x5C 0x97
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00

Cisco 2600 Router

show vlan

이 명령은 설정된 각 VLAN이 L2인지 L3인지 정보를 말해준다.

c2600#show vlan
 
Virtual LAN ID:  1 (Inter Switch Link Encapsulation)
 
   vLAN Trunk Interface:   FastEthernet0/0.1
 
   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.10.1                  40                  38
 
Virtual LAN ID:  2 (Inter Switch Link Encapsulation)
 
   vLAN Trunk Interface:   FastEthernet0/0.2
 
   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.11.1                   9                   9

주 석: 위의 명령어들이 802.1Q 트렁키을 위해 다음과 같이 바뀌었다.

c2600#show vlan
 
Virtual LAN ID:  1 (IEEE 802.1Q Encapsulation)
 
   vLAN Trunk Interface:   FastEthernet0/0.1
 
 다음의 인터페이스들은 NATIVE VLAN으로 구성 되어져 있다.

FastEthernet0/0
 
   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.10.1                   0                   2
 
Virtual LAN ID:  2 (IEEE 802.1Q Encapsulation)
 
   vLAN Trunk Interface:   FastEthernet0/0.2
 
   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.11.1                  42                  19

주 석: 802.1Q 트렁킹을 위해, 12.1(3)T보다 이전의 버전에서 명령어 변경은 다음과 같다.

c2600#show vlan

Virtual LAN ID:  2 (IEEE 802.1Q Encapsulation)

   vLAN Trunk Interface:   FastEthernet0/0.2

   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.11.1                   6                   4

주 석: VLAN1에 어떤 서브 인터페이스도 IEEE 802.1Q encapsulation 구성이 없음을 보여준다.

show interface

이 명령어는 인터페이스의 설정과 운용 상태를 확인하기 위해 사용된다.

c2600#show interfaces fastEthernet 0/0
FastEthernet0/0 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:07, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 1 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     217 packets input, 12884 bytes
     Received 217 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     45 packets output, 6211 bytes, 0 underruns(0/0/0)
     0 output errors, 0 collisions, 4 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
c2600#show interfaces fastEthernet 0/0.1
FastEthernet0/0.1 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Internet address is 10.10.10.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ISL Virtual LAN, Color 1.
  ARP type: ARPA, ARP Timeout 04:00:00
c2600#show interfaces fastEthernet 0/0.2
FastEthernet0/0.2 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Internet address is 10.10.11.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ISL Virtual LAN, Color 2.
  ARP type: ARPA, ARP Timeout 04:00:00

주 석: 802.1Q 트렁킹을 위해서 위의 명령어들이 다음과 같이 바뀌었다.

c2600#show interfaces fastEthernet 0/0.1

FastEthernet0/0.1 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Internet address is 10.10.10.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  1.
  ARP type: ARPA, ARP Timeout 04:00:00
c2600#show interfaces fastEthernet 0/0.2
FastEthernet0/0.2 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Internet address is 10.10.11.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  2.
  ARP type: ARPA, ARP Timeout 04:00:00

Trackback 0 Comment 0