2011. 12. 6. 18:40

구글 안드로이드폰, 정보유출 취약점 공격 코드 주의!

구글 안드로이드 진저브레드 2.3.3 버전 이하의 모든 스마트폰에서 이용자의 정보를 유출시킬 수 있는 취약점에 대한 공격 코드가 공개돼 주의가 요구된다.

스마트 플랫폼 보안 전문 업체인 아이넷캅에서는 지난달 28일 해외 보안 포럼을 통해 공개된 ‘Google 안드로이드 스마트폰 콘텐츠 프로바이더 URI를 통한 파일 유출 취약점’을 분석하여 그 위험성을 확인했다. 

해당 취약점은 이미 지난해인 2010년 11월 18일 최초로 발견된 취약점으로써 1년이 지난 시점에 실제 취약점을 공격하는 코드가 외부에 공개된 것이다.


공격자가 이번 취약점을 악용하여 SMS 스팸 문자나 모바일 메신저 링크, QR 코드 등을 통해 특수하게 조작된 웹 페이지를 사용자가 열어보도록 유도할 경우 정보를 유출하는 공격 스크립트가 실행되면서 사용자 스마트폰에 저장된 개인정보 및 자료 등이 외부로 유출될 수 있다.


물론 허가권 보안 모델이 기본으로 적용되어 있어 Phone 통화 및 문자 내역과 주소록 등의 개인정보는 유출되지 않는 것이 확인되었지만 SD 카드에 저장되는 사진 및 동영상 파일 등의 개 정보들은 유출이 가능한 것을 확인했다.


현재 안드로이드 이클레어 2.0, 2.1 버전부터 프로요 2.2 버전과 진저브레드 2.3.2 버전까지 해당 취약점 영향을 받는 것으로 조사되었다.


아이넷캅 유동훈 연구소장은 “공식 보안 패치가 적용된 안드로이드 최신 버전으로 펌웨어 업그레이드를 진행하고 출처가 불분명한 SMS와 메일 등의 웹 주소 링크, SNS(소셜 네트워크 서비스)의 짧은 주소 링크를 함부로 열람하지 않도록 주의해야 한다”고 당부했다. 해결 방안에 대한 보다 상세 정보는 INetCop 홈페이지(http://inetcop.org/)에 게시된 보안권고문을 참고하면 된다.
 

[김태형 기자(boan@boannews.com)]

출처 : http://www.boannews.com/ 


Trackback 0 Comment 0