2012.05.08 18:44

애플 모바일 운영체제(iOS) 보안 업데이트

□ 개요

   o 최근 애플社에서 모바일운영체제의 취약점을 해결한 iOS 5.1.1을 공개[1]

   o iOS 5.1.1은 iPhone, iPad, iPod Touch에 대한 보안 업데이트를 포함함

   o 이에 국내 iPhone, iPad, iPod Touch 이용자들에게 소프트웨어 업데이트를 권고함

 

□ 설명

   o 애플社에서 4가지 보안 업데이트를 포함한 iOS 5.1.1을 공개[1]

   o 관련 취약점은 다음과 같음

          -  Safari(CVE-2012-0674) : 악의적으로 제작된 웹사이트에 접속할 때 주소창의 URL이 변조되어 공격자 사이트로

        접속되는 취약점

            - WebKit(CVE-2011-3046, CVE-2011-3056) : 악의적으로 제작된 웹사이트에 접속할 때 악성 스크립트가

       실행되는 XSS(Cross-site Scripting) 취약점

              - WebKit(CVE-2012-0672) : 악의적으로 제작된 웹사이트에 접속할 때 프로그램이 비정상적으로

       종료되거나 원격 코드가 실행되는 취약점

  

□ 해당 시스템

   o 영향 받는 소프트웨어

    - 애플 iOS 5.1이하 버전이 설치된 아이폰(아이폰3GS, 아이폰4, 아이폰4S), 아이패드(아패드, 아이패드2)

       및 아이팟 터치

 

□ 해결방안

   o iOS 5.1.1버전으로 업데이트(아이튠즈 이용)

    ① PC에서 아이튠즈를 실행하고 iPhone을 PC와 연결

 


    ② “업데이트” 버튼을 클릭하여 소프트웨어 업데이트



   o iOS 5.1.1버전으로 업데이트(Wi-Fi이용)

    ① [설정]→[일반]→[소프트웨어업데이트] 선택
    ② [다운로드 및 설치]를 선택하여 업데이트

      ※ 3G 모드일때 다운로드 및 설치가 안됨. Wi-Fi 모드로 변환하여 업데이트를 진행
  

 

Wi-Fi 상태                          3G상태

 

□ 용어 정리

   o WebKit : 웹브라우저를 만드는데 필요한 오픈 소스 형태의 프레임워크

   o XSS(Cross Site Scripting) 취약점 : 공격자가 스크립트 언어를 악용하여, 웹페이지에 접근하는 사용자가 악의적인

         스크립트를 실행하게 하는 취약점

 

□ 기타 문의사항

   o 한국인터넷진흥원 인터넷침해대응센터: 국번없이 118

 

[참고사이트]

[1] http://support.apple.com/kb/HT5278


Trackback 1 Comment 0