본문 바로가기

php65

728x90
PHP 다중 취약점 업데이트 □ 개요 o PHP Group은 다중 취약점을 해결한 보안 업데이트를 발표[1] o 공격자는 apache_request_headers()함수에서 발생할 수 있는 버퍼오버플로우 취약점(CVE-2012-2329)과 “php-cgi"에서 소스코드가 노출되는 취약점(CVE-2012-2329)을 악용할 수 있으므로, 최신버전으로 업데이트 권고 □ 영향받는 시스템 o PHP 5.4.2 이하 버전 o PHP 5.3.12 이하 버전 □ 해결방안 o 취약한 PHP버전 이용자 - PHP 5.4.2 또는 PHP 5.3.12 이상 버전으로 업데이트 수행 □ 용어 정리 o PHP : 동적인 웹사이트를 위한 서버 측 스크립트 언어 □ 기타 문의사항 o 한국인터넷진흥원 인터넷침해대응센터: 국번없이 118 [참고사이트][1] htt.. 2012. 5. 10.
국내 공개 웹게시판(익스프레스엔진) XSS 취약점 보안 업데이트 개요 국내 PHP기반의 공개 웹 게시판인 익스프레스엔진에서 XSS 취약점이 발견됨 [1] 취약한 버전을 사용하고 있을 경우, 악의적인 스크립트를 이용하여 관리자 권한탈취, 피싱사이트 유도, 악성코드 경유지/유포지 사이트 유도 등의 피해를 입을 수 있으므로 웹 관리자의 적극적인 조치 필요 해당 시스템 영향 받는 소프트웨어[1] - 익스프레스 엔진1.5.1.8(1.4.5.10포함) 및 이전 버전 해결방안 기존 익스프레스 엔진 사용자는 업데이트가 적용된 상위 버전으로 업그레이드 [2] ※ 패치 작업 이전에 반드시 Database 및 원본 소스코드파일은 백업 필요 익스프레스 엔진을 새로 설치하는 이용자 - 반드시 보안패치가 적용된 최신버전(1.5.1.10)을 설치 용어 정리 PHP : 동적인 웹사이트를 구현을 .. 2012. 3. 2.
국내 공개 웹 게시판(익스프레스엔진) 보안 업데이트 □ 개요 o 국내 PHP기반의 공개 웹 게시판인 익스프레스엔진에서 Cross Site Scripting 취약점이 발견됨 o 취약한 버전을 사용하고 있을 경우, 홈페이지 해킹에 의한 관리자 계정 탈취 등의 피해를 입을 수 있으므로 웹 관리자의 적극적인 조치 필요 □ 해당시스템 o 영향받는 소프트웨어 - 익스프레스 엔진 1.5.1.5 및 이전 버전 □ 해결방안 o 기존 익스프레스 엔진 사용자는 업데이트가 적용된 상위 버전으로 업그레이드 [1] ※ 패치 작업 이전에 원본 파일은 백업 필요 o 익스프레스 엔진을 새로 설치하는 이용자 - 반드시 보안패치가 적용된 최신버전(1.5.1.6 이상)을 설치 □ 용어 정리 o PHP : 동적인 웹사이트를 위한 서버 측 스크립트 언어 o XSS (Cross Site Scri.. 2012. 2. 10.
PHP 원격코드 실행 취약점 보안 업데이트 □ 개요 o PHP 5.3.9 버전의 "php_register_variable_ex()" 함수에서 구현 오류로 인해 원격코드 실행 가능한 취약점이 발견됨[1] o 공격자는 해당 취약점에 영향 받는 시스템에 특수하게 조작된 요청을 전송 할 경우, 영향받는 시스템에 원격코드를 실행시킬 수 있음 o 해당 취약점 정보 공개에 따라 피해를 입을 수 있으므로, 웹서버관리자의 적극적인 조치 필요 □ 해당 시스템 o 영향 받는 시스템 - PHP 5.3.9 버전 □ 해결방안 o 취약한 PHP 버전 사용자 - PHP 5.3.10 이상버전으로 업데이트 수행 [2] □ 용어정리 o PHP : 동적인 웹사이트를 위한 서버 측 스크립트 언어 □ 기타 문의사항 o 한국인터넷진흥원 인터넷침해대응센터: 국번없이 118 [참고사이트] .. 2012. 2. 7.
해시 테이블 구현 취약점 관련 보안 업데이트 □ 개요 o 해시 테이블 구현 오류로 인해 해당 기능을 사용하는 다양한 응용프로그램 및 서비스를 대상으로, 장애를 유발시킬 수 있는 취약점이 발견됨 o 공격자는 해당 취약점에 영향 받는 시스템에 특수하게 조작된 요청을 전송 할 경우, 서비스 거부 상태를 유발시킬 수 있음 □ 해당 시스템 o 영향 받는 시스템 - .NET Framework MS11-100 보안패치 이전 버전 - PHP 5.3.8, 5.4.0RC3 및 이전버전 - Apache Tomcat 5.534, 6.0.34, 7.0.22 및 이전버전 □ 해결방안 o 취약한 .NET Framework 버전 사용자 - 최신 윈도우 보안패치를 적용하여 MS11-100 업데이트 수행 [1] o 취약한 PHP 버전 사용자 - PHP 5.3.9, 5.4.0RC4.. 2012. 1. 3.
728x90